aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntonín Říha <antonin.riha@protonmail.com>2022-05-11 00:31:14 +0200
committerAntonín Říha <antonin.riha@protonmail.com>2022-05-11 00:31:58 +0200
commite7fdba67be95f65add5c19e1d87b7bf5e28d5ddd (patch)
treebb08f79e3855a4e16903d602b4a5760fc5fe0dfb /dev-python/grpclib
parentgames-util/mangohud: make dev-python/mako BDEPEND + remove spdlog patch texts (diff)
downloadguru-e7fdba67be95f65add5c19e1d87b7bf5e28d5ddd.tar.gz
guru-e7fdba67be95f65add5c19e1d87b7bf5e28d5ddd.tar.bz2
guru-e7fdba67be95f65add5c19e1d87b7bf5e28d5ddd.zip
dev-python/grpclib: new ebuild
Signed-off-by: Antonín Říha <antonin.riha@protonmail.com>
Diffstat (limited to 'dev-python/grpclib')
-rw-r--r--dev-python/grpclib/Manifest2
-rw-r--r--dev-python/grpclib/grpclib-0.4.2.ebuild49
-rw-r--r--dev-python/grpclib/grpclib-0.4.3_rc2.ebuild41
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/grpclib/Manifest b/dev-python/grpclib/Manifest
new file mode 100644
index 000000000..95fb988ee
--- /dev/null
+++ b/dev-python/grpclib/Manifest
@@ -0,0 +1,2 @@
+DIST grpclib-0.4.2.tar.gz 116997 BLAKE2B 8a3ad3022a4963f0539c212b66af615f4c1a73cec49801118af25ad141741aed692e16389687f690f885d9f85dc53a5e1b8208a5d8af111c2e50fdefef0684ce SHA512 a25ee2286431d294dd4b07b3ac34387608ca3dbabdf6d54a09b1a33fe66c75ba88f3f5e90160a55dc614871c93bc6ccfb884d149bbd624e13d792b44271b534f
+DIST grpclib-0.4.3_rc2.tar.gz 116904 BLAKE2B c4a0bf70c4f8d218829e10811fb532bcd1bea7eeec10aa2ee06e286af68e653b73d6db1b0e859821d1587fc5fa81e7a8ab2473b24e746b53b1a5134589a6e68c SHA512 185118ce1f1fca4db3dfc8fa781ef7a09f366aa4f0bfb1f37222f307c4d30c9527c5ffd74d4afce1e27cff69c76c6f8e9fb054920a41da000f723e9a79219f07
diff --git a/dev-python/grpclib/grpclib-0.4.2.ebuild b/dev-python/grpclib/grpclib-0.4.2.ebuild
new file mode 100644
index 000000000..8f3375f49
--- /dev/null
+++ b/dev-python/grpclib/grpclib-0.4.2.ebuild
@@ -0,0 +1,49 @@
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python gRPC implementation for asyncio"
+HOMEPAGE="https://github.com/vmagamedov/grpclib"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmagamedov/grpclib"
+else
+ MY_PV="${PV/_rc/rc}"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ SRC_URI="https://github.com/vmagamedov/${PN}/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/h2-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/hpack-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hyperframe-6.0.1[${PYTHON_USEDEP}]
+ >=dev-python/multidict-6.0.2[${PYTHON_USEDEP}]
+ >=dev-python/grpcio-tools-1.43.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ dev-python/Faker[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ 'dev-python/sphinx_rtd_theme'
+
+python_test() {
+ [[ ${EPYTHON} == python3.10 ]] && local EPYTEST_DESELECT=(
+ # does not work in python3.10 due to the bug in ssl https://bugs.python.org/issue46067
+ 'tests/test_client_channel.py::test_default_ssl_context'
+ )
+ epytest
+}
diff --git a/dev-python/grpclib/grpclib-0.4.3_rc2.ebuild b/dev-python/grpclib/grpclib-0.4.3_rc2.ebuild
new file mode 100644
index 000000000..732b33f0d
--- /dev/null
+++ b/dev-python/grpclib/grpclib-0.4.3_rc2.ebuild
@@ -0,0 +1,41 @@
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python gRPC implementation for asyncio"
+HOMEPAGE="https://github.com/vmagamedov/grpclib"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmagamedov/grpclib"
+else
+ MY_PV="${PV/_rc/rc}"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ SRC_URI="https://github.com/vmagamedov/${PN}/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/h2-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/hpack-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hyperframe-6.0.1[${PYTHON_USEDEP}]
+ >=dev-python/multidict-6.0.2[${PYTHON_USEDEP}]
+ >=dev-python/grpcio-tools-1.43.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ dev-python/Faker[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ 'dev-python/sphinx_rtd_theme'