aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-08 21:15:19 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-08 21:16:47 +0500
commit9e4e041c2935336dc4bc615ef36c774d94462013 (patch)
treeb1979a362a6427e32c012c8663e4bc18f6f57d7f /dev-python/hidapi
parentdev-python/daff: bump eapi, add tests (diff)
downloadguru-9e4e041c2935336dc4bc615ef36c774d94462013.tar.gz
guru-9e4e041c2935336dc4bc615ef36c774d94462013.tar.bz2
guru-9e4e041c2935336dc4bc615ef36c774d94462013.zip
dev-python/hidapi: drop old, fix setuptools warning
... bump eapi and python targets Closes: https://bugs.gentoo.org/799644 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/hidapi')
-rw-r--r--dev-python/hidapi/Manifest1
-rw-r--r--dev-python/hidapi/hidapi-0.10.1.ebuild9
-rw-r--r--dev-python/hidapi/hidapi-0.9.0_p3.ebuild31
3 files changed, 5 insertions, 36 deletions
diff --git a/dev-python/hidapi/Manifest b/dev-python/hidapi/Manifest
index d65fe2f8b..257b0a044 100644
--- a/dev-python/hidapi/Manifest
+++ b/dev-python/hidapi/Manifest
@@ -1,2 +1 @@
DIST hidapi-0.10.1.tar.gz 60712 BLAKE2B 9f66015f801a73ad520b303a011edbfecb6b2e79e4366b8e72cc15a4b509cd5744c4c5f9d710b120a44f10cab0c72edf6f679961979d7ad2581edf3238426609 SHA512 681e3691a4b05b13abc38d305c68e448728612442d0ef12ce54d12eeebee6e18d33566c462a276d18ce5e29fad208e6fcde49bbe4b162eae5cd72ce37dea880b
-DIST hidapi-0.9.0.post3.tar.gz 57075 BLAKE2B 7c0c46faa359bf119875846680aadad94e65f5bdd225c11b4fd068cf4fb5b7fba1ed4983bc70610720d5b7ab8a2f7afd96726610309ff35cc5310a237ac117d8 SHA512 606540833459e615a8e50ff3a2c59362dab7d19d42d5e9dc2288c8c8d32e3df7214e758a9814e7de6d26bbdccd76ccf6c652b0bf8ac5b3f46124a9a7b007b971
diff --git a/dev-python/hidapi/hidapi-0.10.1.ebuild b/dev-python/hidapi/hidapi-0.10.1.ebuild
index 5641f6f48..4174ede60 100644
--- a/dev-python/hidapi/hidapi-0.10.1.ebuild
+++ b/dev-python/hidapi/hidapi-0.10.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit distutils-r1
DESCRIPTION="A Cython interface to the hidapi"
@@ -19,9 +19,10 @@ DEPEND="
dev-python/cython[${PYTHON_USEDEP}]
dev-libs/hidapi
"
+RDEPEND="${DEPEND}"
distutils_enable_tests pytest
python_test() {
- pytest -vv tests.py || die "Tests failed with ${EPYTHON}"
+ epytest tests.py
}
diff --git a/dev-python/hidapi/hidapi-0.9.0_p3.ebuild b/dev-python/hidapi/hidapi-0.9.0_p3.ebuild
deleted file mode 100644
index 0693e14c0..000000000
--- a/dev-python/hidapi/hidapi-0.9.0_p3.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-MY_PV=${PV/_p/.post}
-
-DESCRIPTION="A Cython interface to the hidapi"
-HOMEPAGE="https://github.com/trezor/cython-hidapi"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="|| ( BSD GPL-3 )"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-SLOT="0"
-
-DEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-libs/hidapi
-"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-distutils_enable_tests pytest
-
-python_test() {
- pytest -vv tests.py || die "Tests failed with ${EPYTHON}"
-}