aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-04 18:07:10 +1300
committerTheo Anderson <telans@posteo.de>2020-12-04 18:07:10 +1300
commit7a7ffe976dd9dcafa3c7d30d3c327e6f41047c26 (patch)
treecf9ea08c0c87465c37d53c8f877dd81951dd458a /dev-python/hunter
parentdev-python/autoflake: bump to 1.4 (diff)
downloadguru-7a7ffe976dd9dcafa3c7d30d3c327e6f41047c26.tar.gz
guru-7a7ffe976dd9dcafa3c7d30d3c327e6f41047c26.tar.bz2
guru-7a7ffe976dd9dcafa3c7d30d3c327e6f41047c26.zip
dev-python/hunter: bump to 3.3.1
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'dev-python/hunter')
-rw-r--r--dev-python/hunter/Manifest1
-rw-r--r--dev-python/hunter/hunter-3.3.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/hunter/Manifest b/dev-python/hunter/Manifest
index 18d23646b..a814d24eb 100644
--- a/dev-python/hunter/Manifest
+++ b/dev-python/hunter/Manifest
@@ -1 +1,2 @@
DIST hunter-3.1.3.tar.gz 422149 BLAKE2B 2834b3daa6be461b78d468aa331a587a476b7109f5ff9c70b27bb51b26f6a390d2074425f4d98ddc692d4e11f1ee14a77f5066650e82687ebaa586051afab4c8 SHA512 ea9cc935240526d2942568073cecfb2bef32d7caedd0b370850b208a56c652bf356ba0e5675281946419aafd966cbff148490f6f4439d0d808335a3e831adbf7
+DIST hunter-3.3.1.tar.gz 533218 BLAKE2B 9ad62c4c5649b3389a480732a3f6939f54fe39f25362e5f796d78ab8286d6aada326035882d81a09c985765c4acc6283e1bd6665c473ca3edb9a84a6f2b301e6 SHA512 8ac5d2f993bc7c75adae532d4bff5a905c7ec84d32389fcfabb4c5ca3d511a73dc84725d5a450be7d1281e006ec049a5b43c01a79890e0b00302b6b7df291d55
diff --git a/dev-python/hunter/hunter-3.3.1.ebuild b/dev-python/hunter/hunter-3.3.1.ebuild
new file mode 100644
index 000000000..952cd2f05
--- /dev/null
+++ b/dev-python/hunter/hunter-3.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Hunter is a flexible code tracing toolkit"
+HOMEPAGE="
+ https://github.com/ionelmc/python-hunter
+ https://pypi.org/project/hunter
+"
+SRC_URI="https://github.com/ionelmc/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/aspectlib[${PYTHON_USEDEP}]
+ dev-python/hunter[${PYTHON_USEDEP}]
+ dev-python/manhole[${PYTHON_USEDEP}]
+ dev-python/pytest-benchmark[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.3.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/python-${P}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs ">=dev-python/sphinx-py3doc-enhanced-theme-2.3.2"
+
+python_prepare_all() {
+ # all tests in this file fail
+ rm tests/test_remote.py || die
+
+ distutils-r1_python_prepare_all
+}