aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-03 18:38:15 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-03 20:32:01 +0200
commita52df4e30dc351e4e84a77d32b425324d4c916c2 (patch)
treede4ebdc32ae351cab4409013a3b73a5b57e22a23 /dev-python/jsonpath-rw
parentdev-python/cotyledon: initial import (diff)
downloadguru-a52df4e30dc351e4e84a77d32b425324d4c916c2.tar.gz
guru-a52df4e30dc351e4e84a77d32b425324d4c916c2.tar.bz2
guru-a52df4e30dc351e4e84a77d32b425324d4c916c2.zip
dev-python/jsonpath-rw: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/jsonpath-rw')
-rw-r--r--dev-python/jsonpath-rw/Manifest1
-rw-r--r--dev-python/jsonpath-rw/jsonpath-rw-1.4.0.ebuild41
-rw-r--r--dev-python/jsonpath-rw/metadata.xml18
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/jsonpath-rw/Manifest b/dev-python/jsonpath-rw/Manifest
new file mode 100644
index 000000000..161efdd86
--- /dev/null
+++ b/dev-python/jsonpath-rw/Manifest
@@ -0,0 +1 @@
+DIST jsonpath-rw-1.4.0.tar.gz 13814 BLAKE2B 96c17df53db15ea06b8d33231a5349e00d85eb92c9c1da784ee8b1773f1a12791f8dc2a6dc7ec67fde0c8c3cfec0a8fc08e77ff08eeebe4ef699d6d4bdda9276 SHA512 5fcbd832975a32d375fd400ebfb84f083c0e7d8780cc63df730a75cca0224bf32d72cb793fcac63fc3afa9697199d7a569af29961da95494253996cc6e5f63b7
diff --git a/dev-python/jsonpath-rw/jsonpath-rw-1.4.0.ebuild b/dev-python/jsonpath-rw/jsonpath-rw-1.4.0.ebuild
new file mode 100644
index 000000000..af6371fde
--- /dev/null
+++ b/dev-python/jsonpath-rw/jsonpath-rw-1.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A robust and significantly extended implementation of JSONPath for Python"
+HOMEPAGE="
+ https://github.com/kennknowles/python-jsonpath-rw
+ https://pypi.org/project/jsonpath-rw
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --verbose || die
+ py.test -v -v || die
+}
diff --git a/dev-python/jsonpath-rw/metadata.xml b/dev-python/jsonpath-rw/metadata.xml
new file mode 100644
index 000000000..14dc6d8c2
--- /dev/null
+++ b/dev-python/jsonpath-rw/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <description>comaintainers welcome</description>
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/kennknowles/python-jsonpath-rw/issues</bugs-to>
+ <remote-id type="pypi">jsonpath-rw</remote-id>
+ <remote-id type="github">kennknowles/python-jsonpath-rw</remote-id>
+ <maintainer status="unknown">
+ <email>kenn.knowles@gmail.com</email>
+ <name>Kenneth Knowles</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>