aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-10-18 16:45:00 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-10-18 16:45:00 +0500
commit018db33350b625d15e6d5db517e1cd019afbf80d (patch)
tree784d14b465b97fa9bd01f8efc0dc64b8be1906fc /dev-python/manhole
parentapp-forensics/libpreloadvaccine: initial import (diff)
downloadguru-018db33350b625d15e6d5db517e1cd019afbf80d.tar.gz
guru-018db33350b625d15e6d5db517e1cd019afbf80d.tar.bz2
guru-018db33350b625d15e6d5db517e1cd019afbf80d.zip
dev-python/manhole: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/808699 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/manhole')
-rw-r--r--dev-python/manhole/manhole-1.8.0-r1.ebuild43
1 files changed, 22 insertions, 21 deletions
diff --git a/dev-python/manhole/manhole-1.8.0-r1.ebuild b/dev-python/manhole/manhole-1.8.0-r1.ebuild
index a49107d05..191643bea 100644
--- a/dev-python/manhole/manhole-1.8.0-r1.ebuild
+++ b/dev-python/manhole/manhole-1.8.0-r1.ebuild
@@ -3,18 +3,6 @@
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=rdepend
-EPYTEST_DESELECT=(
- "tests/test_manhole.py::test_non_daemon_connection"
- "tests/test_manhole.py::test_daemon_connection"
- "tests/test_manhole.py::test_uwsgi"
- "tests/test_manhole.py::test_fork_exec"
- "tests/test_manhole.py::test_connection_handler_exec[str]"
- "tests/test_manhole.py::test_connection_handler_exec[func]"
- "tests/test_manhole.py::test_environ_variable_activation"
- "tests/test_manhole.py::test_stderr_doesnt_deadlock"
- "tests/test_manhole_cli.py"
-)
PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -25,22 +13,35 @@ HOMEPAGE="
https://pypi.org/project/manhole
"
SRC_URI="https://github.com/ionelmc/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/python-${PN}-${PV}"
+S="${WORKDIR}/python-${P}"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-DEPEND="
- test? (
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/eventlet[${PYTHON_USEDEP}]' python3.8 python3.9)
- )
+BDEPEND="test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/eventlet[${PYTHON_USEDEP}]' \
+ python3.8 python3.9)
+)
"
DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
-distutils_enable_tests --install pytest
distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ "tests/test_manhole.py::test_non_daemon_connection"
+ "tests/test_manhole.py::test_daemon_connection"
+ "tests/test_manhole.py::test_uwsgi"
+ "tests/test_manhole.py::test_fork_exec"
+ "tests/test_manhole.py::test_connection_handler_exec[str]"
+ "tests/test_manhole.py::test_connection_handler_exec[func]"
+ "tests/test_manhole.py::test_environ_variable_activation"
+ "tests/test_manhole.py::test_stderr_doesnt_deadlock"
+ "tests/test_manhole_cli.py"
+)