aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:17:09 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:29:03 +0200
commit31bf152ba6cc3ebc667013e190e26a6d415b1c78 (patch)
treec79c728ace4a7c7b0eedb0e9a60855fd1b9a296e /dev-python/manhole
parentdev-python/pygaljs: new package (diff)
downloadguru-31bf152ba6cc3ebc667013e190e26a6d415b1c78.tar.gz
guru-31bf152ba6cc3ebc667013e190e26a6d415b1c78.tar.bz2
guru-31bf152ba6cc3ebc667013e190e26a6d415b1c78.zip
dev-python/manhole: new package
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/manhole')
-rw-r--r--dev-python/manhole/Manifest1
-rw-r--r--dev-python/manhole/manhole-1.6.0.ebuild47
-rw-r--r--dev-python/manhole/metadata.xml20
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/manhole/Manifest b/dev-python/manhole/Manifest
new file mode 100644
index 000000000..2d8dd7fb8
--- /dev/null
+++ b/dev-python/manhole/Manifest
@@ -0,0 +1 @@
+DIST manhole-1.6.0.tar.gz 30111 BLAKE2B e6cffb465d72d579d3c901b5f163248ea28f3a208d2b487207a4f2d949994b7b778808b19a3bde0047bc71c2fe1865a12f9dcc5ac4f5407745879c8648df6c89 SHA512 179a87529e371c4480b6ab0ad6cc6cc9e3942f4be339cacaf1f1b100e447b8b1f2903a03879e9df3376c86ced4421aa5a16d934c9b250f91715b28d03dca000a
diff --git a/dev-python/manhole/manhole-1.6.0.ebuild b/dev-python/manhole/manhole-1.6.0.ebuild
new file mode 100644
index 000000000..37db2bb6e
--- /dev/null
+++ b/dev-python/manhole/manhole-1.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MYPN="python-${PN}"
+
+DESCRIPTION="Debugging manhole for python application"
+HOMEPAGE="
+ https://github.com/ionelmc/python-manhole
+ https://pypi.org/project/python-manhole
+"
+SRC_URI="https://github.com/ionelmc/${MYPN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ dev-python/pytest-travis-fold[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-servers/uwsgi[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+python_prepare_all() {
+ #no coverage
+ #sed -i 's|--cov-report term-missing||' setup.cfg || die
+ #sed -i 's|nocover: false|nocover: true|' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme \
+ dev-python/sphinxcontrib-napoleon
diff --git a/dev-python/manhole/metadata.xml b/dev-python/manhole/metadata.xml
new file mode 100644
index 000000000..e40749895
--- /dev/null
+++ b/dev-python/manhole/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription>
+Manhole is in-process service that will accept unix domain socket connections and present the stacktraces for all threads and an interactive prompt. It can either work as a python daemon thread waiting for connections at all times or a signal handler (stopping your application and waiting for a connection).
+
+Access to the socket is restricted to the application's effective user id or root.
+
+This is just like Twisted's manhole. It's simpler (no dependencies), it only runs on Unix domain sockets (in contrast to Twisted's manhole which can run on telnet or ssh) and it integrates well with various types of applications.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ionelmc/python-manhole</remote-id>
+ <remote-id type="pypi">manhole</remote-id>
+ </upstream>
+</pkgmetadata>