aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-14 01:23:03 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-14 06:54:15 +0500
commit8a394a3fa8cd59d30225c414bc1f4f23cf96c898 (patch)
treee6cf32f6c84a016b747f8700f77c86424f484bfa /dev-python/manhole
parentdev-python/hunter: drop 3.3.5 (diff)
downloadguru-8a394a3fa8cd59d30225c414bc1f4f23cf96c898.tar.gz
guru-8a394a3fa8cd59d30225c414bc1f4f23cf96c898.tar.bz2
guru-8a394a3fa8cd59d30225c414bc1f4f23cf96c898.zip
dev-python/manhole: bump EAPI and PYTHON_COMPAT
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/manhole')
-rw-r--r--dev-python/manhole/manhole-1.8.0.ebuild54
1 files changed, 26 insertions, 28 deletions
diff --git a/dev-python/manhole/manhole-1.8.0.ebuild b/dev-python/manhole/manhole-1.8.0.ebuild
index e6edae08f..eae6b4e6c 100644
--- a/dev-python/manhole/manhole-1.8.0.ebuild
+++ b/dev-python/manhole/manhole-1.8.0.ebuild
@@ -1,51 +1,49 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
-
inherit distutils-r1
-MY_PN="python-${PN}"
-
DESCRIPTION="Debugging manhole for python application"
HOMEPAGE="
https://github.com/ionelmc/python-manhole
https://pypi.org/project/manhole
"
-SRC_URI="https://github.com/ionelmc/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/ionelmc/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-${PN}-${PV}"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="
- test? (
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-S="${WORKDIR}/${MY_PN}-${PV}"
+BDEPEND="test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/eventlet[${PYTHON_USEDEP}]' python3.8 python3.9)
+)"
-distutils_enable_tests --install pytest
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
+distutils_enable_tests --install pytest
distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme
python_test() {
- epytest \
- --deselect tests/test_manhole.py::test_non_daemon_connection \
- --deselect tests/test_manhole.py::test_daemon_connection \
- --deselect tests/test_manhole.py::test_uwsgi \
- --deselect tests/test_manhole.py::test_fork_exec \
- --deselect tests/test_manhole.py::test_connection_handler_exec[str] \
- --deselect tests/test_manhole.py::test_connection_handler_exec[func] \
- --deselect tests/test_manhole.py::test_environ_variable_activation \
- --deselect tests/test_manhole.py::test_stderr_doesnt_deadlock \
- --deselect tests/test_manhole_cli.py::test_help
+ epytest_args=(
+ --deselect tests/test_manhole.py::test_non_daemon_connection
+ --deselect tests/test_manhole.py::test_daemon_connection
+ --deselect tests/test_manhole.py::test_uwsgi
+ --deselect tests/test_manhole.py::test_fork_exec
+ --deselect tests/test_manhole.py::test_connection_handler_exec[str]
+ --deselect tests/test_manhole.py::test_connection_handler_exec[func]
+ --deselect tests/test_manhole.py::test_environ_variable_activation
+ --deselect tests/test_manhole.py::test_stderr_doesnt_deadlock
+ --deselect tests/test_manhole_cli.py
+ )
+ epytest "${epytest_args[@]}"
}