aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-12-06 14:18:43 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-12-06 15:19:45 +0500
commit9f2ce690d3f794135872703f85365ffec5c3dc30 (patch)
tree52b69c455c63064560ee25c429bbdf0689697804 /dev-python/manhole
parentmedia-fonts/linja-wawa: initial import (diff)
downloadguru-9f2ce690d3f794135872703f85365ffec5c3dc30.tar.gz
guru-9f2ce690d3f794135872703f85365ffec5c3dc30.tar.bz2
guru-9f2ce690d3f794135872703f85365ffec5c3dc30.zip
dev-python/manhole: distutils_install_for_testing
Closes: https://bugs.gentoo.org/828022 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/manhole')
-rw-r--r--dev-python/manhole/manhole-1.8.0-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/manhole/manhole-1.8.0-r1.ebuild b/dev-python/manhole/manhole-1.8.0-r1.ebuild
index 4497fdc9a..dfdfad7db 100644
--- a/dev-python/manhole/manhole-1.8.0-r1.ebuild
+++ b/dev-python/manhole/manhole-1.8.0-r1.ebuild
@@ -32,26 +32,28 @@ BDEPEND="test? (
DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
python_test() {
+ distutils_install_for_testing
+
local -x PYTHONPATH="${S}/src:${PYTHONPATH}"
local EPYTEST_DESELECT=(
tests/test_manhole.py::test_connection_handler_exec
tests/test_manhole.py::test_non_daemon_connection
tests/test_manhole.py::test_daemon_connection
+ tests/test_manhole.py::test_environ_variable_activation
tests/test_manhole.py::test_fork_exec
tests/test_manhole.py::test_uwsgi
tests/test_manhole_cli.py::test_help
- )
- # usually passes but sometimes fails (bug #792225)
- EPYTEST_DESELECT+=( tests/test_manhole.py::test_stderr_doesnt_deadlock )
+ # usually passes but sometimes fails (bug #792225)
+ tests/test_manhole.py::test_stderr_doesnt_deadlock
+ )
if [[ ${EPYTHON} == pypy3 ]]; then
EPYTEST_DESELECT+=(
tests/test_manhole.py::test_log_fh
- tests/test_manhole.py::test_environ_variable_activation
)
fi