aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-14 03:40:57 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-14 03:41:41 +0100
commit9a406990e0b41db2c4d431b8d571dfb321874e9e (patch)
tree9a31d028bd55dd0540a1aa58e0a8778aff9990f3 /dev-python/pg8000
parentdev-python/pip-api: add 0.0.29 (diff)
downloadguru-9a406990e0b41db2c4d431b8d571dfb321874e9e.tar.gz
guru-9a406990e0b41db2c4d431b8d571dfb321874e9e.tar.bz2
guru-9a406990e0b41db2c4d431b8d571dfb321874e9e.zip
dev-python/pg8000: add 1.24.1
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/pg8000')
-rw-r--r--dev-python/pg8000/Manifest1
-rw-r--r--dev-python/pg8000/pg8000-1.24.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pg8000/Manifest b/dev-python/pg8000/Manifest
index 16ea460c3..a2d0e5be9 100644
--- a/dev-python/pg8000/Manifest
+++ b/dev-python/pg8000/Manifest
@@ -1 +1,2 @@
DIST pg8000-1.22.0.tar.gz 116910 BLAKE2B a6779fe30a114f4e66c8a09924a4174ab9c128ee286138b80d60c7cc879c496abd56943c22bee1d396de460002a6971762580112f3dd2808f96f4c46db176e4d SHA512 ec506464a7d13d8befee7f8e0837983c4cbc6193b8ec7d8847c46cb04788c23339db6557b31e88d567e395cb45100e3c0a68ac3ba34a031380a980c24857ed87
+DIST pg8000-1.24.1.tar.gz 118816 BLAKE2B 43ed4cfb1850288f65c7b7d9dc20c0459f381b67829199855d5188d030212bd3ff9a4135258b515f2073e4303b7909d1961e7428cd208bb2dfc52abe35bb02c2 SHA512 3260d74eaefc5bcdf179e509b1ff3aceaeb8bf76f01e1ec6886e79d40b564540686e355c8de3fca9ace34447bdbb3ae3b2616e5941655eff890a28e336abef57
diff --git a/dev-python/pg8000/pg8000-1.24.1.ebuild b/dev-python/pg8000/pg8000-1.24.1.ebuild
new file mode 100644
index 000000000..d51a98bf1
--- /dev/null
+++ b/dev-python/pg8000/pg8000-1.24.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Pure-Python PostgreSQL Driver"
+HOMEPAGE="
+ https://github.com/tlocke/pg8000
+ https://pypi.org/project/pg8000/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/scramp-1.4.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-db/postgresql
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-benchmark[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="test" # tests require a running postgresql
+
+distutils_enable_tests pytest