aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-04-04 23:21:49 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-04-04 23:53:27 +0200
commitaf188d129027656919c24a6d89dec8eeb13afb07 (patch)
treee75ee1fedaad22e472cb7bd45349979e0abef9b0 /dev-python/portio
parentapp-misc/fetsh: Version bump 1.9 (diff)
downloadguru-af188d129027656919c24a6d89dec8eeb13afb07.tar.gz
guru-af188d129027656919c24a6d89dec8eeb13afb07.tar.bz2
guru-af188d129027656919c24a6d89dec8eeb13afb07.zip
dev-python/portio: new package
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/portio')
-rw-r--r--dev-python/portio/Manifest1
-rw-r--r--dev-python/portio/metadata.xml13
-rw-r--r--dev-python/portio/portio-0.5.ebuild20
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/portio/Manifest b/dev-python/portio/Manifest
new file mode 100644
index 000000000..92971e787
--- /dev/null
+++ b/dev-python/portio/Manifest
@@ -0,0 +1 @@
+DIST portio-0.5.tar.gz 134136 BLAKE2B a330caad064beb05ec7bb313f1f381c3fd5000a7b7d7f1f90ebe4a1a1767cbfe0e9441c368f053121322a35f342c69c6b4232be1773efd23f90bbc071d6858a9 SHA512 363a81d2c98cd0c0113a9d37082b7f017517239a02dbb0077922f3a32b918a92a7d9526cdf7a31d1ab80883ad4746bc86b49ea92eae7cc0d20f703a5f8eda777
diff --git a/dev-python/portio/metadata.xml b/dev-python/portio/metadata.xml
new file mode 100644
index 000000000..cfa4420f2
--- /dev/null
+++ b/dev-python/portio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>PortIO is a Python wrapper for the port I/O macros like outb, inb, etc. provided by the C library on Linux x86 platforms. Both python 2 and 3 are supported. This module is useful when a general pourpose port I/O at the low level is needed. Programmers that want to perform I/O on the parallel port at an higher level, will be better satisfied by the pyParallel module. A similar module Ioport has inspired the writing of PortIO.</longdescription>
+ <upstream>
+ <changelog>http://portio.inrim.it/#changelog</changelog>
+ <maintainer>
+ <name>Fabrizio Pollastri</name>
+ <email>f.pollastri@inrim.it</email>
+ </maintainer>
+ <remote-id type="pypi">portio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/portio/portio-0.5.ebuild b/dev-python/portio/portio-0.5.ebuild
new file mode 100644
index 000000000..583a66e48
--- /dev/null
+++ b/dev-python/portio/portio-0.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python low level port I/O for Linux x86"
+HOMEPAGE="
+ http://portio.inrim.it
+ https://pypi.org/project/portio
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( index.rst )