aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-03 10:52:21 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-03 10:52:21 +0200
commit0ef1df6a8741e456a193eec6d339d9b5b57f0b58 (patch)
tree1bd94144bc97d982a049ef243808dfd09e55e192 /dev-python/pure-protobuf
parentdev-python/redbaron: use python_prepare_all (diff)
downloadguru-0ef1df6a8741e456a193eec6d339d9b5b57f0b58.tar.gz
guru-0ef1df6a8741e456a193eec6d339d9b5b57f0b58.tar.bz2
guru-0ef1df6a8741e456a193eec6d339d9b5b57f0b58.zip
dev-python/pure-protobuf: enable tests
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/pure-protobuf')
-rw-r--r--dev-python/pure-protobuf/Manifest2
-rw-r--r--dev-python/pure-protobuf/pure-protobuf-2.0.0.ebuild13
2 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/pure-protobuf/Manifest b/dev-python/pure-protobuf/Manifest
index 432ab18a8..2bfe6a066 100644
--- a/dev-python/pure-protobuf/Manifest
+++ b/dev-python/pure-protobuf/Manifest
@@ -1 +1 @@
-DIST pure-protobuf-2.0.0.tar.gz 14331 BLAKE2B 9936341ddc17918972141f9d167af70e281082cc154d2e96207f7b3fc8d07519284a332976bb694c63c9ec348b2b7076f3f74305af52edff4afe00593047461d SHA512 6eb3d85b82d9742c1b87bc46c261e707439f16a034824aa1751232ebf534be1bf5f7d7b0053834a1412e6309c73f1dcc323851ffffff262c8bbe266b5153051b
+DIST pure-protobuf-2.0.0.tar.gz 17576 BLAKE2B 49979559b3c08eb9abdddfa80e78ca4d953347a005b042d5b69aa4c6caef185c358408b1bf54d9161c0cadf69422b1ed033c74b324e947328c55f8b6ec4fd050 SHA512 a8d5211f34d0d6fab28d8b54fb3bb87d41a13b61a01f6f79f47fc1c0eafaf1ab17ddfd323c1035fcd4794b7b23823f48f38af3aa485835683f824cdd4689b098
diff --git a/dev-python/pure-protobuf/pure-protobuf-2.0.0.ebuild b/dev-python/pure-protobuf/pure-protobuf-2.0.0.ebuild
index bed1ae6aa..1325cff90 100644
--- a/dev-python/pure-protobuf/pure-protobuf-2.0.0.ebuild
+++ b/dev-python/pure-protobuf/pure-protobuf-2.0.0.ebuild
@@ -12,8 +12,19 @@ HOMEPAGE="
https://github.com/eigenein/protobuf
https://pypi.org/project/pure-protobuf/
"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/eigenein/protobuf/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
+
+S="${WORKDIR}/protobuf-${PV}"
+
+distutils_enable_tests pytest
+
+python_install() {
+ # Package installs 'tests' package which is forbidden and likely a bug in the build system.
+ rm -r tests || die
+
+ python_foreach_impl distutils-r1_python_install
+}