aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-04 10:38:13 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-04 10:38:13 +0200
commit5a2e27ff548a3508efca16179b32b370366f70ea (patch)
tree04140d60685925ccfd1d217f9795a75d95cf8fce /dev-python/pure-protobuf
parentnet-misc/rpki-client: New ebuild (diff)
downloadguru-5a2e27ff548a3508efca16179b32b370366f70ea.tar.gz
guru-5a2e27ff548a3508efca16179b32b370366f70ea.tar.bz2
guru-5a2e27ff548a3508efca16179b32b370366f70ea.zip
dev-python/pure-protobuf: patch exclude variable in setup.py
we used the python_foreach_impl function wrong python_install is already run with python_foreach_impl, thus the function should not be used inside python_install for this there is python_install_all, but this is run after python_foreach_impl python_install so we again get the '${P} installs tests' error. Instead I just patched a fix, this fix is also already in upstream master Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/pure-protobuf')
-rw-r--r--dev-python/pure-protobuf/files/pure-protobuf-do-not-install-tests.patch13
-rw-r--r--dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild9
-rw-r--r--dev-python/pure-protobuf/pure-protobuf-2.0.0.ebuild32
3 files changed, 14 insertions, 40 deletions
diff --git a/dev-python/pure-protobuf/files/pure-protobuf-do-not-install-tests.patch b/dev-python/pure-protobuf/files/pure-protobuf-do-not-install-tests.patch
new file mode 100644
index 000000000..6da5a8db4
--- /dev/null
+++ b/dev-python/pure-protobuf/files/pure-protobuf-do-not-install-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index deb6c95..2ae6c69 100644
+--- a/setup.py
++++ b/setup.py
+@@ -9,7 +9,7 @@ setup(
+ author='Pavel Perestoronin',
+ author_email='eigenein@gmail.com',
+ url='https://github.com/eigenein/protobuf',
+- packages=find_packages(exclude=['tests']),
++ packages=find_packages(exclude=['tests*']),
+ zip_safe=True,
+ install_requires=[
+ 'dataclasses>=0.6,<1.0; python_version < "3.7"',
diff --git a/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild b/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild
index e240faf39..5cb93b655 100644
--- a/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild
+++ b/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild
@@ -22,11 +22,4 @@ S="${WORKDIR}/protobuf-${PV}"
distutils_enable_tests pytest
-python_install() {
- # Package installs 'tests' package which is forbidden and likely a bug in the build system.
- rm -r tests || die
-
- # Previously it did not actually install any python libs
- python_foreach_impl esetup.py install
- python_foreach_impl python_optimize
-}
+PATCHES="${FILESDIR}/${PN}-do-not-install-tests.patch"
diff --git a/dev-python/pure-protobuf/pure-protobuf-2.0.0.ebuild b/dev-python/pure-protobuf/pure-protobuf-2.0.0.ebuild
deleted file mode 100644
index e240faf39..000000000
--- a/dev-python/pure-protobuf/pure-protobuf-2.0.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A more Pythonic version of doxypy, a Doxygen filter for Python"
-HOMEPAGE="
- https://github.com/eigenein/protobuf
- https://pypi.org/project/pure-protobuf/
-"
-SRC_URI="https://github.com/eigenein/protobuf/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-S="${WORKDIR}/protobuf-${PV}"
-
-distutils_enable_tests pytest
-
-python_install() {
- # Package installs 'tests' package which is forbidden and likely a bug in the build system.
- rm -r tests || die
-
- # Previously it did not actually install any python libs
- python_foreach_impl esetup.py install
- python_foreach_impl python_optimize
-}