aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-05-03 21:10:00 +0200
committerMaciej Barć <xgqt@protonmail.com>2020-05-03 21:10:11 +0200
commit8541788e878d1b02a64296b448dac39f4d0f7d66 (patch)
treea984491b1961f43765edd301c337dedb8d3390ff /dev-python/pure-protobuf
parentdev-python/pure-protobuf: fix package installation (diff)
downloadguru-8541788e878d1b02a64296b448dac39f4d0f7d66.tar.gz
guru-8541788e878d1b02a64296b448dac39f4d0f7d66.tar.bz2
guru-8541788e878d1b02a64296b448dac39f4d0f7d66.zip
dev-python/pure-protobuf: version 2.0.0 revision bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Maciej Barć <xgqt@protonmail.com>
Diffstat (limited to 'dev-python/pure-protobuf')
-rw-r--r--dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild b/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild
new file mode 100644
index 000000000..e240faf39
--- /dev/null
+++ b/dev-python/pure-protobuf/pure-protobuf-2.0.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A more Pythonic version of doxypy, a Doxygen filter for Python"
+HOMEPAGE="
+ https://github.com/eigenein/protobuf
+ https://pypi.org/project/pure-protobuf/
+"
+SRC_URI="https://github.com/eigenein/protobuf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/protobuf-${PV}"
+
+distutils_enable_tests pytest
+
+python_install() {
+ # Package installs 'tests' package which is forbidden and likely a bug in the build system.
+ rm -r tests || die
+
+ # Previously it did not actually install any python libs
+ python_foreach_impl esetup.py install
+ python_foreach_impl python_optimize
+}