aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2020-09-02 18:55:55 +0200
committerMatthias Coppens <coppens.matthias.abc@gmail.com>2020-09-02 18:56:13 +0200
commitc3ba9251933daab06313ea2e567a907ea8fe2eac (patch)
tree10cc849384bceca9050e92d45a87bb5584ee74a0 /dev-python/pyfiglet
parentmedia-plugins/qt-avif-image-plugin: 0.3.2 version bump (diff)
downloadguru-c3ba9251933daab06313ea2e567a907ea8fe2eac.tar.gz
guru-c3ba9251933daab06313ea2e567a907ea8fe2eac.tar.bz2
guru-c3ba9251933daab06313ea2e567a907ea8fe2eac.zip
dev-python/pyfiglet: Tarballs from pypi instead of github
The tarballs on pypi are more up to date than the ones on github. The versioning on pypi is kinda weird: X.Y.postZ. I used X.Y.Z for the ebuilds. Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com>
Diffstat (limited to 'dev-python/pyfiglet')
-rw-r--r--dev-python/pyfiglet/Manifest3
-rw-r--r--dev-python/pyfiglet/pyfiglet-0.8.0.ebuild5
-rw-r--r--dev-python/pyfiglet/pyfiglet-0.8.1.ebuild28
-rw-r--r--dev-python/pyfiglet/pyfiglet-9999.ebuild5
4 files changed, 38 insertions, 3 deletions
diff --git a/dev-python/pyfiglet/Manifest b/dev-python/pyfiglet/Manifest
index c8670c405..2d03afcd9 100644
--- a/dev-python/pyfiglet/Manifest
+++ b/dev-python/pyfiglet/Manifest
@@ -1 +1,2 @@
-DIST pyfiglet-0.8.0.tar.gz 1412945 BLAKE2B 601d8edd22d1cd3bb1999a1000717ac5074024c1511068f613a22c21663b6f62fa3671bc329a99a7527444f8694c9c6342a34ff0bef52c64daa4f66d18f5dfec SHA512 47cbe6f539d2559fb7c545d42cb0a085c85d7a18729453f0b3f62a735f580026b5c9fe40eef896c038cfc9a5400b6bc6dc382e7014c6733d2797bb03c2a9dc49
+DIST pyfiglet-0.8.0.tar.gz 634587 BLAKE2B 6ceec287f854662a0d0cbb6de285c91f1088e6fa2626a26445a98c18f98c8e6fb648b6f6f2fc1cfb160657423a24ec8ec8f9183e078393f336edc1db08eb8e9e SHA512 43f0497ae86139e8f64c45e41e575aa82eee574331739e96c555ca33e8f6900df6487d3220667188891eacd56e00d716d427479337fe5d6b2efdaa6aaaa64376
+DIST pyfiglet-0.8.1.tar.gz 634618 BLAKE2B 49268581974e72f28ddb11785a1629a4ac2696bcdd57710147cafdcf7709be8c67bdf03e5ccdb1655a9be6eb8a83baf4ca5ae0a6412e2318d0923376558b8d49 SHA512 3b8c7b4c9ae48466da3ccc6711aac9c35b08a373abbdda66c60a62f17ba6edd316b0d5e3085613f7c44fbaa2f02acc4a5b3830a31d22437d9261863878421400
diff --git a/dev-python/pyfiglet/pyfiglet-0.8.0.ebuild b/dev-python/pyfiglet/pyfiglet-0.8.0.ebuild
index 7822410e7..bb2344481 100644
--- a/dev-python/pyfiglet/pyfiglet-0.8.0.ebuild
+++ b/dev-python/pyfiglet/pyfiglet-0.8.0.ebuild
@@ -15,7 +15,10 @@ then
inherit git-r3
EGIT_REPO_URI="https://github.com/pwaller/pyfiglet.git"
else
- SRC_URI="https://github.com/pwaller/pyfiglet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ MY_PV="$(ver_cut 1-2).post$(ver_cut 3)"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://files.pythonhosted.org/packages/source/p/pyfiglet/${MY_P}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
diff --git a/dev-python/pyfiglet/pyfiglet-0.8.1.ebuild b/dev-python/pyfiglet/pyfiglet-0.8.1.ebuild
new file mode 100644
index 000000000..bb2344481
--- /dev/null
+++ b/dev-python/pyfiglet/pyfiglet-0.8.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Pure-python FIGlet implementation"
+HOMEPAGE="https://pypi.org/project/pyfiglet/ https://github.com/pwaller/pyfiglet"
+
+if [[ "${PV}" == 9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pwaller/pyfiglet.git"
+else
+ MY_PV="$(ver_cut 1-2).post$(ver_cut 3)"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://files.pythonhosted.org/packages/source/p/pyfiglet/${MY_P}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RESTRICT="mirror test"
diff --git a/dev-python/pyfiglet/pyfiglet-9999.ebuild b/dev-python/pyfiglet/pyfiglet-9999.ebuild
index 7822410e7..bb2344481 100644
--- a/dev-python/pyfiglet/pyfiglet-9999.ebuild
+++ b/dev-python/pyfiglet/pyfiglet-9999.ebuild
@@ -15,7 +15,10 @@ then
inherit git-r3
EGIT_REPO_URI="https://github.com/pwaller/pyfiglet.git"
else
- SRC_URI="https://github.com/pwaller/pyfiglet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ MY_PV="$(ver_cut 1-2).post$(ver_cut 3)"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://files.pythonhosted.org/packages/source/p/pyfiglet/${MY_P}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi