aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2020-07-21 12:05:22 +0200
committerMatthias Coppens <coppens.matthias.abc@gmail.com>2020-07-21 12:32:37 +0200
commit22bb3f3bb982229af2594eecfa93ced32a78d928 (patch)
treecea3da79eee2e83440e6e3b921dc43b2845ccb76 /dev-python/pyinquirer/pyinquirer-9999.ebuild
parentdev-python/pyinquirer: Cleaned deps (diff)
downloadguru-22bb3f3bb982229af2594eecfa93ced32a78d928.tar.gz
guru-22bb3f3bb982229af2594eecfa93ced32a78d928.tar.bz2
guru-22bb3f3bb982229af2594eecfa93ced32a78d928.zip
dev-python/pyinquirer: Added pytest
Added pytest, but also restricted it, because it has an outdated dep Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com>
Diffstat (limited to 'dev-python/pyinquirer/pyinquirer-9999.ebuild')
-rw-r--r--dev-python/pyinquirer/pyinquirer-9999.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-python/pyinquirer/pyinquirer-9999.ebuild b/dev-python/pyinquirer/pyinquirer-9999.ebuild
index 59db9d222..7e133e682 100644
--- a/dev-python/pyinquirer/pyinquirer-9999.ebuild
+++ b/dev-python/pyinquirer/pyinquirer-9999.ebuild
@@ -20,6 +20,7 @@ esac
PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
distutils_enable_sphinx docs
+distutils_enable_tests pytest
DESCRIPTION="A Python module for common interactive command line UIs"
HOMEPAGE="${EGIT_REPO_URI}"
@@ -27,11 +28,22 @@ LICENSE="MIT"
SLOT="0"
+# Tests are outdated, they fail for >dev-python/ptyprocess-0.5.1
+RESTRICT="test"
+
RDEPEND="
>=dev-python/prompt_toolkit-3.0.0[${PYTHON_USEDEP}]
<dev-python/prompt_toolkit-3.1.0[${PYTHON_USEDEP}]
>=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ >=dev-python/pytest-html-1.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.15.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/ptyprocess-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/regex-2016.11.21[${PYTHON_USEDEP}] )"
src_prepare() {
default