aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-01-08 23:34:12 +1300
committerTheo Anderson <telans@posteo.de>2021-01-08 23:34:12 +1300
commitd4ef124994bb8654b56010a882a57fcd729f35eb (patch)
treee70910896c0862aa4264e33f1ce103b700a5d3c8 /dev-python/pykeepass
parentdev-python/pykeepass: fix pycryptodome imports (diff)
downloadguru-d4ef124994bb8654b56010a882a57fcd729f35eb.tar.gz
guru-d4ef124994bb8654b56010a882a57fcd729f35eb.tar.bz2
guru-d4ef124994bb8654b56010a882a57fcd729f35eb.zip
dev-python/pykeepass: drop old
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'dev-python/pykeepass')
-rw-r--r--dev-python/pykeepass/pykeepass-3.2.0.ebuild33
-rw-r--r--dev-python/pykeepass/pykeepass-3.2.1.ebuild32
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/pykeepass/pykeepass-3.2.0.ebuild b/dev-python/pykeepass/pykeepass-3.2.0.ebuild
deleted file mode 100644
index 6fca8bdb0..000000000
--- a/dev-python/pykeepass/pykeepass-3.2.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 ) # not all dependency are 3.8 ready
-
-inherit distutils-r1 eutils toolchain-funcs
-
-DESCRIPTION="Python library to interact with keepass databases (supports KDBX3 and KDBX4) "
-HOMEPAGE="https://github.com/libkeepass/pykeepass"
-SRC_URI="https://github.com/libkeepass/pykeepass/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
- >=dev-python/construct-2.9.4[${PYTHON_USEDEP}]
- >=dev-python/future-0.17.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.3.4[${PYTHON_USEDEP}]
- >=dev-python/pycryptodome-3.8.2[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/0001-setup.py-exclude-tests-directory.patch" )
-
-python_test() {
- "${EPYTHON}" tests/tests.py -v || die
-}
diff --git a/dev-python/pykeepass/pykeepass-3.2.1.ebuild b/dev-python/pykeepass/pykeepass-3.2.1.ebuild
deleted file mode 100644
index 7a28d45a2..000000000
--- a/dev-python/pykeepass/pykeepass-3.2.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to interact with keepass databases (supports KDBX3 and KDBX4) "
-HOMEPAGE="https://github.com/libkeepass/pykeepass"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
- >=dev-python/construct-2.9.4[${PYTHON_USEDEP}]
- >=dev-python/future-0.17.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.3.4[${PYTHON_USEDEP}]
- >=dev-python/pycryptodome-3.8.2[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/0001-setup.py-exclude-tests-directory.patch" )
-
-python_test() {
- "${EPYTHON}" tests/tests.py -v || die
-}