aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGábor Oszkár Dénes <gaboroszkar@protonmail.com>2022-03-30 19:01:13 +0200
committerGábor Oszkár Dénes <gaboroszkar@protonmail.com>2022-03-30 19:01:13 +0200
commitce2693bc87dd7b0e2f7cc98ddae9fe6c08d4087f (patch)
tree16092c6df97528e36abb3a5af9729a8e8d72487a /dev-python/pylatexenc
parentdev-python/retworkx: new package (diff)
downloadguru-ce2693bc87dd7b0e2f7cc98ddae9fe6c08d4087f.tar.gz
guru-ce2693bc87dd7b0e2f7cc98ddae9fe6c08d4087f.tar.bz2
guru-ce2693bc87dd7b0e2f7cc98ddae9fe6c08d4087f.zip
dev-python/pylatexenc: new package
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Gábor Oszkár Dénes <gaboroszkar@protonmail.com>
Diffstat (limited to 'dev-python/pylatexenc')
-rw-r--r--dev-python/pylatexenc/Manifest1
-rw-r--r--dev-python/pylatexenc/metadata.xml14
-rw-r--r--dev-python/pylatexenc/pylatexenc-2.10.ebuild19
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pylatexenc/Manifest b/dev-python/pylatexenc/Manifest
new file mode 100644
index 000000000..a340c67f9
--- /dev/null
+++ b/dev-python/pylatexenc/Manifest
@@ -0,0 +1 @@
+DIST pylatexenc-2.10.tar.gz 721836 BLAKE2B 8512e052271c127809105280360706217f5134b2349d4b21dcec720addb4cff4157173f8350115de4142aea491da2efb1a2854b4310c48ec98061470be21654e SHA512 9728731e0c84324685b77ce17fae0bea445815e2c54394d2722c4412bbd914da49280ef36b5f3a0a0346e5d2129ca2d8d3b3b92356de3c6af9eed4247cf8bd43
diff --git a/dev-python/pylatexenc/metadata.xml b/dev-python/pylatexenc/metadata.xml
new file mode 100644
index 000000000..4bb5426ae
--- /dev/null
+++ b/dev-python/pylatexenc/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- comaintainers-welcomed -->
+ <maintainer type="person">
+ <email>gaboroszkar@protonmail.com</email>
+ <name>Gábor Oszkár Dénes</name>
+ </maintainer>
+ <longdescription>
+ Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion.
+ The pylatexenc.latexencode module provides a function unicode_to_latex() which converts a unicode string into LaTeX text and escape sequences. It should recognize accented characters and most math symbols. A couple of switches allow you to alter how this function behaves.
+ You can also run latexencode in command-line to convert plain unicode text (from the standard input or from files given on the command line) into LaTeX code, written on to the standard output.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pylatexenc/pylatexenc-2.10.ebuild b/dev-python/pylatexenc/pylatexenc-2.10.ebuild
new file mode 100644
index 000000000..dcf1d618c
--- /dev/null
+++ b/dev-python/pylatexenc/pylatexenc-2.10.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion"
+HOMEPAGE="https://github.com/phfaist/pylatexenc"
+SRC_URI="https://github.com/phfaist/pylatexenc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest