aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-14 00:55:49 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-14 06:53:23 +0500
commit9105d0ffe0796b8c7d5eeefbaea65012676c6e7e (patch)
treed5825eb24fde5a669cc66b773dfc8cc4fb56aad8 /dev-python/pytest-instafail
parentdev-python/aspectlib: bump EAPI and PYTHON_COMPAT (diff)
downloadguru-9105d0ffe0796b8c7d5eeefbaea65012676c6e7e.tar.gz
guru-9105d0ffe0796b8c7d5eeefbaea65012676c6e7e.tar.bz2
guru-9105d0ffe0796b8c7d5eeefbaea65012676c6e7e.zip
dev-python/pytest-instafail: bump EAPI and python
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/pytest-instafail')
-rw-r--r--dev-python/pytest-instafail/pytest-instafail-0.4.2.ebuild30
1 files changed, 7 insertions, 23 deletions
diff --git a/dev-python/pytest-instafail/pytest-instafail-0.4.2.ebuild b/dev-python/pytest-instafail/pytest-instafail-0.4.2.ebuild
index 0599a10ad..44da12ecc 100644
--- a/dev-python/pytest-instafail/pytest-instafail-0.4.2.ebuild
+++ b/dev-python/pytest-instafail/pytest-instafail-0.4.2.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Plugin for pytest that shows failures and errors instantly"
@@ -16,28 +15,13 @@ SRC_URI="https://github.com/pytest-dev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-RDEPEND="
- >=dev-python/pytest-2.9[${PYTHON_USEDEP}]
-"
-BDEPEND="test? (
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
+RDEPEND=">=dev-python/pytest-2.9[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pexpect[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
-python_prepare_all() {
- # pexpect.exceptions.EOF: End Of File (EOF). Exception style platform.
- sed -i -e 's:test_print_stacktrace_once_with_pdb:_&:' \
- test_instafail.py || die
-
- distutils-r1_python_prepare_all
-}
-
python_test() {
- distutils_install_for_testing
- pytest -vv || die "Testsuite failed under ${EPYTHON}"
+ epytest --deselect test_instafail.py::TestInstafailingTerminalReporter::test_print_stacktrace_once_with_pdb
}