aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:03:53 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:29:02 +0200
commitd5e2803e89dc0c1682820b7df2dd26b9a226b585 (patch)
treea735fe386f42e8c80d04cc3739291a1e2d2e2bbf /dev-python/pytest-sugar
parentgames-action/multimc: version bump 0.6.11 (diff)
downloadguru-d5e2803e89dc0c1682820b7df2dd26b9a226b585.tar.gz
guru-d5e2803e89dc0c1682820b7df2dd26b9a226b585.tar.bz2
guru-d5e2803e89dc0c1682820b7df2dd26b9a226b585.zip
dev-python/pytest-sugar: new package
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/pytest-sugar')
-rw-r--r--dev-python/pytest-sugar/Manifest1
-rw-r--r--dev-python/pytest-sugar/metadata.xml19
-rw-r--r--dev-python/pytest-sugar/pytest-sugar-0.9.2.ebuild29
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pytest-sugar/Manifest b/dev-python/pytest-sugar/Manifest
new file mode 100644
index 000000000..123b31e5e
--- /dev/null
+++ b/dev-python/pytest-sugar/Manifest
@@ -0,0 +1 @@
+DIST pytest-sugar-0.9.2.tar.gz 12677 BLAKE2B 9ef5119479ce1333bf86844e8f959d5e50f1f656fff7a871acb9aa5bd7478bafa34819c4db8ad8a8f105807cf444544846bf02049fbd6802636e5a3f123a11ab SHA512 9a1f30e35cb503f1afec6a1e18ad2d013b005627891021171ccc6f94d3aebe45a724db0615ba75e2befc074e7b77dd0627b5ffb8876906d434bd95cf5984b5ad
diff --git a/dev-python/pytest-sugar/metadata.xml b/dev-python/pytest-sugar/metadata.xml
new file mode 100644
index 000000000..c1fe544d0
--- /dev/null
+++ b/dev-python/pytest-sugar/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription>
+pytest-sugar changes the look and feel of pytest, Python testing tool, by adding a progressbar and instafailing tests
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Teemu/pytest-sugar</remote-id>
+ <remote-id type="pypi">pytest-sugar</remote-id>
+ <maintainer status="unknown">
+ <email>janne.vanhala@gmail.com</email>
+ <name>Janne Vanhala</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-sugar/pytest-sugar-0.9.2.ebuild b/dev-python/pytest-sugar/pytest-sugar-0.9.2.ebuild
new file mode 100644
index 000000000..e3f00c37c
--- /dev/null
+++ b/dev-python/pytest-sugar/pytest-sugar-0.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for pytest that changes the default look and feel of pytest"
+HOMEPAGE="
+ https://pivotfinland.com/pytest-sugar
+ https://github.com/Teemu/pytest-sugar
+ https://pypi.org/project/pytest-sugar
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-14.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14[${PYTHON_USEDEP}]
+ >=dev-python/termcolor-1.1.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest