aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-17 21:47:22 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-17 21:48:44 +0200
commit183c193867c144a19e11a321b9a069c4d2f7add3 (patch)
treea03e9df9ba64957db58e1316c0dab5585c0eb8ce /dev-python/python-blazarclient
parentTODO.md: remove mbdyn (diff)
downloadguru-183c193867c144a19e11a321b9a069c4d2f7add3.tar.gz
guru-183c193867c144a19e11a321b9a069c4d2f7add3.tar.bz2
guru-183c193867c144a19e11a321b9a069c4d2f7add3.zip
dev-python/python-blazarclient: new version
Closes: https://bugs.gentoo.org/800383 Closes: https://bugs.gentoo.org/800386 Closes: https://bugs.gentoo.org/815544 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/python-blazarclient')
-rw-r--r--dev-python/python-blazarclient/Manifest2
-rw-r--r--dev-python/python-blazarclient/python-blazarclient-3.1.1.ebuild35
-rw-r--r--dev-python/python-blazarclient/python-blazarclient-3.3.1.ebuild44
3 files changed, 45 insertions, 36 deletions
diff --git a/dev-python/python-blazarclient/Manifest b/dev-python/python-blazarclient/Manifest
index 4706c1788..ae3177804 100644
--- a/dev-python/python-blazarclient/Manifest
+++ b/dev-python/python-blazarclient/Manifest
@@ -1 +1 @@
-DIST python-blazarclient-3.1.1.tar.gz 36460 BLAKE2B b19595a3cf52da6d298e5006eada7a68c28f396c8143bbed2f22b45e910d136b54bf3d3fde95bd4fc02887bffd206d10629e923e7d81289af643e44b751c0926 SHA512 91cf8004f83494299e11d8c419f183c45726a1b9baec09ffdb719ff8db3cb91967c24a4ac684e227c87015bc00733b03fb132e34fe2fdc773164373e3fd10561
+DIST python-blazarclient-3.3.1.tar.gz 40395 BLAKE2B 86658277a8a8aa5730afe8860f1f551200230364c08b71389da60e60315db49bc6a860f5fc23cea2186db15d3258c0a3a70b30ea9450165f9c5a2459ba082f78 SHA512 f460cff35a11acddf2a2215c1740e2ffb7448f20b9298c5538a08e77d5444fce3d39005693b7b34a751fc87fb7972a09d669b6076e672a8ccd63dae8be405263
diff --git a/dev-python/python-blazarclient/python-blazarclient-3.1.1.ebuild b/dev-python/python-blazarclient/python-blazarclient-3.1.1.ebuild
deleted file mode 100644
index eead0dd2b..000000000
--- a/dev-python/python-blazarclient/python-blazarclient-3.1.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_8 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="This is a client for the OpenStack Blazar API"
-HOMEPAGE="https://github.com/openstack/python-blazarclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0"
-DEPEND="${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
- !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
-"
diff --git a/dev-python/python-blazarclient/python-blazarclient-3.3.1.ebuild b/dev-python/python-blazarclient/python-blazarclient-3.3.1.ebuild
new file mode 100644
index 000000000..a8d09ef43
--- /dev/null
+++ b/dev-python/python-blazarclient/python-blazarclient-3.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Blazar API"
+HOMEPAGE="
+ https://github.com/openstack/python-blazarclient
+ https://opendev.org/openstack/python-blazarclient
+ https://pypi.org/project/python-blazarclient
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/hacking-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest