aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-28 01:03:49 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-28 01:03:49 +0200
commitb7eb33eea5b34ac165ddb5dd1c252dc980a050eb (patch)
treeaf85fac0d4f530b8373ae975a470b7bc841c1f3d /dev-python/sanic-routing
parentdev-python/sanic: add 21.6.0 (diff)
downloadguru-b7eb33eea5b34ac165ddb5dd1c252dc980a050eb.tar.gz
guru-b7eb33eea5b34ac165ddb5dd1c252dc980a050eb.tar.bz2
guru-b7eb33eea5b34ac165ddb5dd1c252dc980a050eb.zip
dev-python/sanic-routing: add 0.7.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/sanic-routing')
-rw-r--r--dev-python/sanic-routing/Manifest1
-rw-r--r--dev-python/sanic-routing/sanic-routing-0.7.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sanic-routing/Manifest b/dev-python/sanic-routing/Manifest
index 2a45ff580..fba40beaa 100644
--- a/dev-python/sanic-routing/Manifest
+++ b/dev-python/sanic-routing/Manifest
@@ -1 +1,2 @@
DIST sanic-routing-0.6.2.tar.gz 14854 BLAKE2B c268244b18531b220eacaa4aa5d6b23612e9f3a27774df65c35b12645bcc18916142c304c07e59a64c950f1f1e7c8e0c34c9c605b1478293e22708c20ba3bc36 SHA512 8bbbae9424bd4e39c8549f70263f9a4847b5f81441152e671e7b8976372b4eecabfde90428bd4eb220f4a44e39239c63f3f2bf429b30ab0f649c80549966a65f
+DIST sanic-routing-0.7.0.tar.gz 23633 BLAKE2B df5a3d122b00d958e1bd262b56e7000aa404a1aa28eaf599d50e826bdb7d9cb94c85843047b3ee9924686ad21d06082956f921e78b6b0e5bf9f20ae0d925b165 SHA512 de7e31c5f464becd3bb36cf6e9b00c2419e54771a406cc02eac6b22dbdd4c60380db52c76e1cddf28dd8387bca185e1f8156b963dbf995a9329ccd9ad25a9627
diff --git a/dev-python/sanic-routing/sanic-routing-0.7.0.ebuild b/dev-python/sanic-routing/sanic-routing-0.7.0.ebuild
new file mode 100644
index 000000000..8bb2c6ee8
--- /dev/null
+++ b/dev-python/sanic-routing/sanic-routing-0.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Internal handler routing for Sanic"
+HOMEPAGE="
+ https://pypi.python.org/pypi/sanic-routing
+ https://github.com/sanic-org/sanic-routing
+"
+SRC_URI="https://github.com/sanic-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/sanic[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest