aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-28 11:48:25 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-28 12:00:14 +0100
commit40249ee752058af76afdd020820d42750dc9682e (patch)
tree259af5eb7ae77ceb65d2a9d1197b99d9c3ae77f5 /dev-python/sphinx-autodoc-typehints
parentdev-python/sphobjinv: add py3_7 (diff)
downloadguru-40249ee752058af76afdd020820d42750dc9682e.tar.gz
guru-40249ee752058af76afdd020820d42750dc9682e.tar.bz2
guru-40249ee752058af76afdd020820d42750dc9682e.zip
dev-python/sphinx-autodoc-typehints: add py3_7
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.10.3.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.10.3.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.10.3.ebuild
index 8b4b1fc11..f5dff9751 100644
--- a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.10.3.ebuild
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.10.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -22,8 +22,10 @@ BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
-DEPEND="test? ( dev-python/sphobjinv[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}] )"
+DEPEND="test? (
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )"
distutils_enable_tests pytest