aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-02-03 18:45:21 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-02-03 18:45:21 +0100
commit7d099febc40ace52dec92b312a0292bdcaa394e4 (patch)
tree593408690dd4d64166d3e492cfade0eaa0b88070 /dev-python/sphinxcontrib-trio
parentdev-python/curio: Concurrent I/O (diff)
downloadguru-7d099febc40ace52dec92b312a0292bdcaa394e4.tar.gz
guru-7d099febc40ace52dec92b312a0292bdcaa394e4.tar.bz2
guru-7d099febc40ace52dec92b312a0292bdcaa394e4.zip
dev-python/sphinxcontrib-trio: Make Sphinx better at docum. func. and meth.
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/sphinxcontrib-trio')
-rw-r--r--dev-python/sphinxcontrib-trio/Manifest1
-rw-r--r--dev-python/sphinxcontrib-trio/metadata.xml9
-rw-r--r--dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.0.ebuild26
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-trio/Manifest b/dev-python/sphinxcontrib-trio/Manifest
new file mode 100644
index 000000000..0992ef5cd
--- /dev/null
+++ b/dev-python/sphinxcontrib-trio/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-trio-1.1.0.tar.gz 23372 BLAKE2B 3b9c651ea575efd53848135533e531f25aeb0b45ee3d57722e7bed324c13fe7bea5eb4a1ac529913a999241c3346f8eee3d6c5e68a2ac7a1676b1e721e3c923d SHA512 d7de31d396aaee2836f854bdeba75eb5748890428601ed9f6aca1386c8c7b347ff86680bbe7257387d461f2ebdd98a6145d4887277263d40fff5450cd31e38a1
diff --git a/dev-python/sphinxcontrib-trio/metadata.xml b/dev-python/sphinxcontrib-trio/metadata.xml
new file mode 100644
index 000000000..628ab2017
--- /dev/null
+++ b/dev-python/sphinxcontrib-trio/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.0.ebuild b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.0.ebuild
new file mode 100644
index 000000000..e592dc298
--- /dev/null
+++ b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Make Sphinx better at documenting Python functions and methods"
+HOMEPAGE="https://github.com/python-trio/sphinxcontrib-trio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest