aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-09 18:42:07 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-09 19:00:52 +0200
commit9aa9c45f635cde503bb7473990b7b9ac1c79d45e (patch)
tree3fc047b19eb3980d5d3a313c1b6f9295a5bcb855 /dev-python/thriftrw
parentdev-python/pymemcache: add mock test dependency (diff)
downloadguru-9aa9c45f635cde503bb7473990b7b9ac1c79d45e.tar.gz
guru-9aa9c45f635cde503bb7473990b7b9ac1c79d45e.tar.bz2
guru-9aa9c45f635cde503bb7473990b7b9ac1c79d45e.zip
dev-python/thriftrw: tool:pytest
Closes: https://bugs.gentoo.org/817203 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/thriftrw')
-rw-r--r--dev-python/thriftrw/files/thriftrw-1.8.1-tool-pytest.patch11
-rw-r--r--dev-python/thriftrw/thriftrw-1.8.1.ebuild5
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-python/thriftrw/files/thriftrw-1.8.1-tool-pytest.patch b/dev-python/thriftrw/files/thriftrw-1.8.1-tool-pytest.patch
new file mode 100644
index 000000000..5bb3774c6
--- /dev/null
+++ b/dev-python/thriftrw/files/thriftrw-1.8.1-tool-pytest.patch
@@ -0,0 +1,11 @@
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -2,7 +2,7 @@
+ create-wheel = yes
+ python-file-with-version = thriftrw/__init__.py
+
+-[pytest]
++[tool:pytest]
+ addopts = --tb short --benchmark-autosave --benchmark-save-data
+
+ [egg_info]
diff --git a/dev-python/thriftrw/thriftrw-1.8.1.ebuild b/dev-python/thriftrw/thriftrw-1.8.1.ebuild
index 7ae0e668c..cfe3df642 100644
--- a/dev-python/thriftrw/thriftrw-1.8.1.ebuild
+++ b/dev-python/thriftrw/thriftrw-1.8.1.ebuild
@@ -26,6 +26,9 @@ DEPEND="
)
"
-PATCHES=( "${FILESDIR}/${P}-no-install-examples.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-no-install-examples.patch"
+ "${FILESDIR}/${P}-tool-pytest.patch"
+)
distutils_enable_tests pytest