aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-18 17:51:44 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-18 17:51:44 +0200
commit4c482d2e2473bded8e7f6f2d4846b840b5e7f946 (patch)
tree843f41a2d786aefdcd7523b5cce98b445c8d2416 /dev-python/trueskill/trueskill-0.4.5_p20191014.ebuild
parentdev-python/pytest-cython: pypy3 and python3.8 (diff)
downloadguru-4c482d2e2473bded8e7f6f2d4846b840b5e7f946.tar.gz
guru-4c482d2e2473bded8e7f6f2d4846b840b5e7f946.tar.bz2
guru-4c482d2e2473bded8e7f6f2d4846b840b5e7f946.zip
dev-python/trueskill: python3.8
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/trueskill/trueskill-0.4.5_p20191014.ebuild')
-rw-r--r--dev-python/trueskill/trueskill-0.4.5_p20191014.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/trueskill/trueskill-0.4.5_p20191014.ebuild b/dev-python/trueskill/trueskill-0.4.5_p20191014.ebuild
new file mode 100644
index 000000000..c5c3ab349
--- /dev/null
+++ b/dev-python/trueskill/trueskill-0.4.5_p20191014.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+COMMIT="91c29b1ab6cd86d6d68fc983fd7ceba3a88ad544"
+
+DESCRIPTION="Python Implementation of the TrueSkill, Glicko and Elo Ranking Algorithms"
+HOMEPAGE="
+ https://trueskill.org
+ https://github.com/sublee/trueskill
+ https://pypi.org/project/trueskill
+"
+SRC_URI="https://github.com/sublee/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND=""
+DEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/almost-0.1.5[${PYTHON_USEDEP}]
+ >=dev-python/mpmath-0.17[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+distutils_enable_tests setup.py
+#docs require a py2 only sphinx theme