aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGábor Oszkár Dénes <gaboroszkar@protonmail.com>2022-04-10 20:45:58 +0200
committerGábor Oszkár Dénes <gaboroszkar@protonmail.com>2022-04-10 20:45:58 +0200
commit78e27b835d92071648f7f530c56fcac03d2648f8 (patch)
tree3c31cdfe26be20d6c53a4f4b8983b775f2c9dfd8 /dev-python/tweedledum
parentdev-python/pysubs2: add 1.4.2, drop 1.4.0 (diff)
downloadguru-78e27b835d92071648f7f530c56fcac03d2648f8.tar.gz
guru-78e27b835d92071648f7f530c56fcac03d2648f8.tar.bz2
guru-78e27b835d92071648f7f530c56fcac03d2648f8.zip
dev-python/tweedledum: Fix pre-stripped QA notice
Closes: https://bugs.gentoo.org/836802 Signed-off-by: Gábor Oszkár Dénes <gaboroszkar@protonmail.com>
Diffstat (limited to 'dev-python/tweedledum')
-rw-r--r--dev-python/tweedledum/tweedledum-1.1.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/tweedledum/tweedledum-1.1.1.ebuild b/dev-python/tweedledum/tweedledum-1.1.1.ebuild
index 649aedc95..d9d47d339 100644
--- a/dev-python/tweedledum/tweedledum-1.1.1.ebuild
+++ b/dev-python/tweedledum/tweedledum-1.1.1.ebuild
@@ -25,6 +25,11 @@ BDEPEND="
distutils_enable_tests pytest
+python_compile() {
+ local -x SKBUILD_CONFIGURE_OPTIONS="-DCMAKE_BUILD_TYPE=RelWithDebInfo"
+ distutils-r1_python_compile
+}
+
python_test() {
epytest python/test
}