aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-14 02:58:21 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-14 03:41:40 +0100
commitc2f8595afe81be2d508a2a8fc50739b5e39d8ba4 (patch)
tree8aa308655b71cd3c4e45b8e853aec67bee94858f /dev-python/uharfbuzz
parentmedia-libs/libjxl: update live ebuild (diff)
downloadguru-c2f8595afe81be2d508a2a8fc50739b5e39d8ba4.tar.gz
guru-c2f8595afe81be2d508a2a8fc50739b5e39d8ba4.tar.bz2
guru-c2f8595afe81be2d508a2a8fc50739b5e39d8ba4.zip
dev-python/uharfbuzz: add 0.22.0, drop 0.18.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/uharfbuzz')
-rw-r--r--dev-python/uharfbuzz/Manifest2
-rw-r--r--dev-python/uharfbuzz/uharfbuzz-0.22.0.ebuild (renamed from dev-python/uharfbuzz/uharfbuzz-0.18.0.ebuild)11
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/uharfbuzz/Manifest b/dev-python/uharfbuzz/Manifest
index 512dcec3d..d2cce7beb 100644
--- a/dev-python/uharfbuzz/Manifest
+++ b/dev-python/uharfbuzz/Manifest
@@ -1,2 +1,2 @@
-DIST uharfbuzz-0.18.0.tar.gz 33469 BLAKE2B ec255a4d6f9a74b12fd2a2b16f4309a223a50a8a6eea62d51d74dcd911b9300282576c66ec92cd28b00b48734a279391b62fe76ae64604f3e69df002f5e9568d SHA512 faf75e885e64ffdd28613c0ceeb30fc3ac4936cb252c8ff7e396c89b86195bf77f0f2135846152b2b8e949f8f806e9ddd75f42f00bb11514cd806062a06e2701
DIST uharfbuzz-0.21.0.tar.gz 34064 BLAKE2B ad8ba13e53cba90794af6d9e99a555d0a266c584894ddc9cc90a9b86002cdeec438c68fa395a90d4e9119574bffd140a824c8acec8b4d5661c0013f8693a2a95 SHA512 090e408163e59d796ff9a9a7b2dca9e7ca00277ffc80139066a287f489d7358681b9eadf4a7bf5e5a7e7457c18fb30ed27d7ae2b71bfcf9cc48362a6c0793085
+DIST uharfbuzz-0.22.0.tar.gz 34454 BLAKE2B 32bbb07f94ed532cfd153bac8164c0444cae9ff0b0d5af870a7e656cf7493926b8c78f868e70e111df9f4286a4779872be5430e020e59527e92843365cb42eb9 SHA512 c30b7d6f4981defd88cda4c178adbab31262bcedd9ccc0969ae1b7bee02b4846e69cecd33ab240af84581d1a34d54167fd8603ade7403f898cf03b4936287792
diff --git a/dev-python/uharfbuzz/uharfbuzz-0.18.0.ebuild b/dev-python/uharfbuzz/uharfbuzz-0.22.0.ebuild
index f58cb51b3..90c61b347 100644
--- a/dev-python/uharfbuzz/uharfbuzz-0.18.0.ebuild
+++ b/dev-python/uharfbuzz/uharfbuzz-0.22.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-DISTUTILS_USE_SETUPTOOLS="pyproject.toml"
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -19,11 +19,12 @@ SLOT="0"
RDEPEND=">=media-libs/harfbuzz-2.8.1[experimental(-)]"
DEPEND="
${RDEPEND}
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.28.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-2.1[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.31[${PYTHON_USEDEP}]
"
-PATCHES=( "${FILESDIR}/${P}-system-harfbuzz.patch" )
+PATCHES=( "${FILESDIR}/${PN}-0.18.0-system-harfbuzz.patch" )
distutils_enable_tests pytest