aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-31 19:57:55 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-31 19:57:55 +0200
commit3f8ac57d5934cb96a2ca0bda759ed8ed951538f0 (patch)
tree4d9be1d32ea5652cffb24ac3112b68b312dab21c /dev-python/uvicorn/uvicorn-0.11.8.ebuild
parentgames-util/legendary: use single python target. (diff)
downloadguru-3f8ac57d5934cb96a2ca0bda759ed8ed951538f0.tar.gz
guru-3f8ac57d5934cb96a2ca0bda759ed8ed951538f0.tar.bz2
guru-3f8ac57d5934cb96a2ca0bda759ed8ed951538f0.zip
dev-python/uvicorn: version bump
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/uvicorn/uvicorn-0.11.8.ebuild')
-rw-r--r--dev-python/uvicorn/uvicorn-0.11.8.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/uvicorn/uvicorn-0.11.8.ebuild b/dev-python/uvicorn/uvicorn-0.11.8.ebuild
new file mode 100644
index 000000000..5b595c1db
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.11.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+DOCBUILDER="mkdocs"
+DOCDEPEND="dev-python/mkdocs-material"
+
+inherit distutils-r1 docs eutils
+
+DESCRIPTION="The lightning-fast ASGI server"
+HOMEPAGE="https://www.uvicorn.org/
+ https://github.com/encode/uvicorn"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/h11[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/uvloop-0.14.0[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/websockets-8.0[${PYTHON_USEDEP}]
+ dev-python/httptools[${PYTHON_USEDEP}]
+ >=dev-python/watchgod-0.6[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # do not install LICENSE to /usr/
+ sed -i -e '/data_files/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "asyncio event loop on top of libuv" dev-python/uvloop
+ optfeature "websockets support using wsproto" dev-python/wsproto
+ optfeature "websockets support using websockets" dev-python/websockets
+ optfeature "httpstools package for http protocol" dev-python/httptools
+ optfeature "efficient debug reload" dev-python/watchgod
+}