aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-27 23:06:54 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-27 23:24:15 +0200
commitae5316183f18e37ff8e046c2e32d98ed508dfe31 (patch)
tree28716a71e947827cf719118f4b275231076fc03f /dev-python/validators/validators-0.14.3.ebuild
parentdev-python/pytest-cython: dependency cleanup (diff)
downloadguru-ae5316183f18e37ff8e046c2e32d98ed508dfe31.tar.gz
guru-ae5316183f18e37ff8e046c2e32d98ed508dfe31.tar.bz2
guru-ae5316183f18e37ff8e046c2e32d98ed508dfe31.zip
dev-python/validators: version bump, dep cleanup
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/validators/validators-0.14.3.ebuild')
-rw-r--r--dev-python/validators/validators-0.14.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/validators/validators-0.14.3.ebuild b/dev-python/validators/validators-0.14.3.ebuild
new file mode 100644
index 000000000..71435e7da
--- /dev/null
+++ b/dev-python/validators/validators-0.14.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Data Validation for Humans"
+HOMEPAGE="
+ https://github.com/kvesteri/validators
+ https://pypi.org/project/validators
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+#not really required
+# test? (
+# >=dev-python/isort-4.2.2[${PYTHON_USEDEP}]
+# )
+
+distutils_enable_tests pytest
+
+#issues with sphinx.ext.pngmath https://github.com/kvesteri/validators/issues/156
+distutils_enable_sphinx docs "<dev-python/sphinx-1.8"