aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-05 03:01:19 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-05 03:01:19 +0200
commitd5b78154dd9e51bba4e0afa9b04f09b2ba80dedc (patch)
tree2fe164daf620f41ddf152121c750c9039ebc312d /dev-python/webpy
parentdev-python/yara-python: link to libyara.so (diff)
downloadguru-d5b78154dd9e51bba4e0afa9b04f09b2ba80dedc.tar.gz
guru-d5b78154dd9e51bba4e0afa9b04f09b2ba80dedc.tar.bz2
guru-d5b78154dd9e51bba4e0afa9b04f09b2ba80dedc.zip
dev-python/webpy: ebuild maintenance
Closes: https://bugs.gentoo.org/788319 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/webpy')
-rw-r--r--dev-python/webpy/webpy-0.62.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/dev-python/webpy/webpy-0.62.ebuild b/dev-python/webpy/webpy-0.62.ebuild
index 5adfaa913..083e62602 100644
--- a/dev-python/webpy/webpy-0.62.ebuild
+++ b/dev-python/webpy/webpy-0.62.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A web framework for python that is as simple as it is powerful"
HOMEPAGE="
- https://webpy.org/
+ https://webpy.org
https://github.com/webpy/webpy
+ https://pypi.org/project/web.py
"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -18,12 +19,7 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="
- dev-python/cheroot[${PYTHON_USEDEP}]
-"
-BDEPEND="test? (
- >=dev-python/pytest-4.6.2[${PYTHON_USEDEP}]
-)"
+RDEPEND="dev-python/cheroot[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
distutils_enable_sphinx docs
@@ -33,3 +29,12 @@ src_prepare() {
rm tests/test_db.py
default
}
+
+python_test() {
+ #https://github.com/webpy/webpy/issues/712
+ #https://github.com/webpy/webpy/issues/713
+ epytest -vv \
+ --deselect tests/test_application.py::ApplicationTest::test_routing \
+ --deselect tests/test_session.py::DiskStoreTest::testStoreConcurrent \
+ || die
+}