aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-11 21:36:26 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-11 21:57:24 +0100
commit55ebc1ab3f34018b4ad1fde54a8c4c63c36a8ff1 (patch)
tree97e5ccf90574d67cf5abbffea1618ba060e81b34 /dev-python/wsgi_intercept
parentdev-python/xattr: add 0.9.9 (diff)
downloadguru-55ebc1ab3f34018b4ad1fde54a8c4c63c36a8ff1.tar.gz
guru-55ebc1ab3f34018b4ad1fde54a8c4c63c36a8ff1.tar.bz2
guru-55ebc1ab3f34018b4ad1fde54a8c4c63c36a8ff1.zip
dev-python/wsgi_intercept: add 1.9.3
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/wsgi_intercept')
-rw-r--r--dev-python/wsgi_intercept/Manifest1
-rw-r--r--dev-python/wsgi_intercept/wsgi_intercept-1.9.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/wsgi_intercept/Manifest b/dev-python/wsgi_intercept/Manifest
index 3c3189d40..95c20a033 100644
--- a/dev-python/wsgi_intercept/Manifest
+++ b/dev-python/wsgi_intercept/Manifest
@@ -1 +1,2 @@
DIST wsgi_intercept-1.9.2.tar.gz 29083 BLAKE2B 97eda40f40f0ea00ff213f2222310ce6c77ee9c822e89330ed8a277f32851d06bdf1050629e69677cf7fb00d04128403c5a89aec1d03d796fdbb65e8f3e4e9b6 SHA512 a313fe6302c9f168bd050c83ded1d58ef74feb54870197eb85b3527c2cc77eb76b4ca61ff4b554e13cca10ec7106ad9ba35c9a41a00bbd82ef39a26df2af7769
+DIST wsgi_intercept-1.9.3.tar.gz 30002 BLAKE2B 65b7b39543dc486d8ea394b093a3892bdbd7b8e8314a3b839af13ca7abc79f0397092b0d908a873821b1d42d713f5fdd64d2cd815498c7e4f77300725b8ab30c SHA512 b23cbbe20299dad413db0130bf9b055b58ad0a8349d18d9a3eb22cec4db6c9c570785c2ba29245ac52fa1c340a80cb7eb18c04b7bd75dd57961ae8c5142eabdc
diff --git a/dev-python/wsgi_intercept/wsgi_intercept-1.9.3.ebuild b/dev-python/wsgi_intercept/wsgi_intercept-1.9.3.ebuild
new file mode 100644
index 000000000..fe2323fdb
--- /dev/null
+++ b/dev-python/wsgi_intercept/wsgi_intercept-1.9.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="wsgi_intercept installs a WSGI application in place of a real URI for testing"
+HOMEPAGE="
+ https://pypi.org/project/wsgi-intercept/
+ https://github.com/cdent/wsgi-intercept
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="test"
+PROPERTIES="test_network"
+
+distutils_enable_tests pytest