aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-27 17:54:09 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-27 18:03:26 +0100
commit19e84ceea1bb2b7390418c8ca6eabdac9c40b019 (patch)
treeec14236f6a6d1778b051a4f6b23b36a9964bc19e /dev-python
parentdev-python/mkdocs-material: pypi homepage (diff)
downloadguru-19e84ceea1bb2b7390418c8ca6eabdac9c40b019.tar.gz
guru-19e84ceea1bb2b7390418c8ca6eabdac9c40b019.tar.bz2
guru-19e84ceea1bb2b7390418c8ca6eabdac9c40b019.zip
dev-python/wcmatch: new package
Package-Manager: Portage-2.3.96, Repoman-2.3.21 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wcmatch/Manifest1
-rw-r--r--dev-python/wcmatch/metadata.xml44
-rw-r--r--dev-python/wcmatch/wcmatch-6.0.1.ebuild35
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/wcmatch/Manifest b/dev-python/wcmatch/Manifest
new file mode 100644
index 0000000000..d4809995dd
--- /dev/null
+++ b/dev-python/wcmatch/Manifest
@@ -0,0 +1 @@
+DIST wcmatch-6.0.1.tar.gz 89466 BLAKE2B ccbc397c0c67f6eba55875ba540aa2705f12808e2eb1e57417beed44fc5ee5234023de439d30f966c158d263154bdd3882ce361b77aab12f1365d172f425ad11 SHA512 aec942c1754103d9938189dbb8ea8b62d8621137b8b51e48095fa4d313cfa120764414345aa3b5d263e2fd29219bf7bd1fa1d238f16521421761853d43596bbc
diff --git a/dev-python/wcmatch/metadata.xml b/dev-python/wcmatch/metadata.xml
new file mode 100644
index 0000000000..85785fc160
--- /dev/null
+++ b/dev-python/wcmatch/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facelessuser/wcmatch</remote-id>
+ <remote-id type="pypi">wcmatch</remote-id>
+ </upstream>
+ <longdescription lang="en">
+Wildcard Match provides an enhanced fnmatch, glob, and pathlib library in order to provide
+file matching and globbing that more closely follows the features found in Bash. In some
+ways these libraries are similar to Python's builtin libraries as they provide a similar
+interface to match, filter, and glob the file system. But they also include a number of
+features found in Bash's globbing such as backslash escaping, brace expansion, extended
+glob pattern groups, etc. They also add a number of new useful functions as well, such as
+globmatch which functions like fnmatch, but for paths.
+Wildcard Match also adds a file search utility called wcmatch that is built on top of fnmatch and globmatch. It was
+originally written for Rummage, but split out into this project to be used by other
+projects that may find its approach useful.
+Bash is used as a guide when making decisions on behavior for fnmatch and glob. Behavior may differ from Bash version to Bash version,
+but an attempt is made to keep Wildcard Match up with the latest relevant changes. With
+all of this said, there may be a few corner cases in which we've intentionally chosen to
+not exactly mirror Bash. If an issue is found where Wildcard Match seems to deviate in an
+illogical way, we'd love to hear about it in the issue tracker.
+Features
+A quick overview of Wildcard Match's
+Features:
+ Provides an interface comparable to Python's builtin in fnamtch, glob, and pathlib.
+ Allows for a much more configurable experience when matching or globbing with many more features. Adds support for ** in glob.
+ Adds support for escaping characters with \.
+ Add support for POSIX style character classes inside sequences: [[:alnum:]], etc. The C locale is used for byte strings and Unicode properties for Unicode strings.
+ Adds support for brace expansion: a{b,{c,d}} --> ab ac ad.
+ Adds support for expanding ~ or ~username to the appropriate user path.
+ Adds support for extended match patterns: @(...), +(...), *(...), ?(...), and !(...).
+ Adds ability to match path names via the path centric globmatch.
+ Provides a pathlib variant that uses Wildcard Match's glob library instead of Python's default.
+ Provides an alternative file crawler called wcmatch.
+ And more...
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/wcmatch/wcmatch-6.0.1.ebuild b/dev-python/wcmatch/wcmatch-6.0.1.ebuild
new file mode 100644
index 0000000000..2e302e4bd8
--- /dev/null
+++ b/dev-python/wcmatch/wcmatch-6.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+#DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Wildcard/glob file name matcher"
+HOMEPAGE="
+ https://github.com/facelessuser/wcmatch
+ https://pypi.org/project/wcmatch"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/backrefs-4.1[${PYTHON_USEDEP}]
+ >=dev-python/bracex-2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ )
+"
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/src \
+ dev-python/mkdocs-git-revision-date-localized-plugin \
+ dev-python/mkdocs_pymdownx_material_extras \
+ dev-python/pyspelling