aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-29 14:42:06 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-29 14:42:06 +0200
commit2b0cf5abf1d1c2c15c43b5aad02f031224808504 (patch)
tree97956ed0f0365f4c3867a3749d65c35b7a0d99a4 /dev-python
parentdev-util/quilttools: Add patch and bump python version (diff)
downloadguru-2b0cf5abf1d1c2c15c43b5aad02f031224808504.tar.gz
guru-2b0cf5abf1d1c2c15c43b5aad02f031224808504.tar.bz2
guru-2b0cf5abf1d1c2c15c43b5aad02f031224808504.zip
dev-python/spotipy: version bump 2.14.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/spotipy/Manifest2
-rw-r--r--dev-python/spotipy/spotipy-2.14.0.ebuild (renamed from dev-python/spotipy/spotipy-2.13.0.ebuild)5
2 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index 9e0962c49..605240f41 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1 +1 @@
-DIST spotipy-2.13.0.tar.gz 89735 BLAKE2B 79e8f8d0c64cc100301362891fc63f232d6197dd68d30df239b0eb53ab5ec8b44ad347adc1c49c0aea95abf4d689cd3c1e291df4586dfb43a8a77cb15f503547 SHA512 992ea7a7681a5179dea0f94fd6e0b1e9ef456f25d6386bebba7b5d71e394d227f671be81bba88578e1bd81e185c6dee710168696be8f026ecbf76da90bd35515
+DIST spotipy-2.14.0.tar.gz 96116 BLAKE2B 9a7db96487c055706705bcd3aa58755f9c6b706fa85d323c153278050fffc04419fac742bc9c21518d74da7e83e964df67f67995bdd6ae1e2fa195bc5035d2ad SHA512 1cd1fa21c1bc41424c36ffdb7acf324c0992277992cd16b512c6d7f0d081aaa5d188895c541bc0c49f0316655665f2ce0465e4ec0943efa6455bd93ea9cbe5bf
diff --git a/dev-python/spotipy/spotipy-2.13.0.ebuild b/dev-python/spotipy/spotipy-2.14.0.ebuild
index 6a64b518b..06b99a23b 100644
--- a/dev-python/spotipy/spotipy-2.13.0.ebuild
+++ b/dev-python/spotipy/spotipy-2.14.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -23,7 +23,7 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
"
-DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
distutils_enable_sphinx docs
distutils_enable_tests pytest
@@ -38,6 +38,7 @@ python_prepare_all() {
# need internet access
sed -i -e 's:test_spotify_client_credentials_get_access_token:_&:' \
tests/unit/test_oauth.py || die
+
distutils-r1_python_prepare_all
}