aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-17 03:47:39 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-17 03:49:27 +0200
commit5e16dbd3b23bb298666bc9a9782b053fb8ea7024 (patch)
treef583fd41eee2d086ab968f76646addc53277ec67 /dev-python
parentdev-R/plogr: new (virtual-ish) package (diff)
downloadguru-5e16dbd3b23bb298666bc9a9782b053fb8ea7024.tar.gz
guru-5e16dbd3b23bb298666bc9a9782b053fb8ea7024.tar.bz2
guru-5e16dbd3b23bb298666bc9a9782b053fb8ea7024.zip
dev-python/webpy: bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webpy/Manifest1
-rw-r--r--dev-python/webpy/metadata.xml7
-rw-r--r--dev-python/webpy/webpy-0.51_p20200405.ebuild43
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/webpy/Manifest b/dev-python/webpy/Manifest
index 7c425da5d..7493c9bfa 100644
--- a/dev-python/webpy/Manifest
+++ b/dev-python/webpy/Manifest
@@ -1,2 +1,3 @@
DIST webpy-0.40.tar.gz 103372 BLAKE2B 3c9f9a3a1be57794589321c6845b691e45956cc9a55988e4dd4fe2ba056bb6118258c441ca219ae214a967f27637e26d03c5cc9052e6f869c75e4ce0458b4f20 SHA512 84553c916cdcbf0f994839c9293f881d0eee9450dfbfa571bb208ef47c5308569d8c2b89732ef85be92f9f8c4fb87838e1507566019d5d381fbb51419bfd64f8
DIST webpy-0.50.tar.gz 105473 BLAKE2B d535016c8e97d06c122e03a3c9888c00415bf9bb12b54812f73d6505eca21ff6f8765d7b3438760ad29f9dbece84e1ccfa5d4aeba8a02298604ca95126643ec5 SHA512 935689e9ee21b41ea942b314c304f934a83dbc522ee99773a74adb7eea2a44bc2fe5e9f28b1c9dfcdd6daa6c6f599b176b31a880520c8f0af64ba89bf76af1f3
+DIST webpy-0.51_p20200405.tar.gz 103748 BLAKE2B 070d08306b1fd32a660cdc77655ce7982f4abeacde95e0c05a59b53170655fad6c76d29bbfe6cd496575f59874ccccef2140ffbe4d7521cb140d71eac8b7f95e SHA512 cedbf05c92eb4688c9854d3cdf99938d4ff076f85da593c762f378de579cd2bd0b29012390c22722a64e1383edd186758fadf4a75d4217d95a0c4de9809bf18d
diff --git a/dev-python/webpy/metadata.xml b/dev-python/webpy/metadata.xml
index 709f24749..cf901666c 100644
--- a/dev-python/webpy/metadata.xml
+++ b/dev-python/webpy/metadata.xml
@@ -7,6 +7,13 @@
</maintainer>
<upstream>
<remote-id type="github">webpy/web.py</remote-id>
+ <doc lang="en">https://webpy.org/docs</doc>
+ <bugs-to>https://github.com/webpy/webpy/issues</bugs-to>
+ <changelog>https://raw.githubusercontent.com/webpy/webpy/master/ChangeLog.txt</changelog>
+ <maintainer>
+ <name>Anand Chitipothu</name>
+ <email>anandology@gmail.com</email>
+ </maintainer>
</upstream>
<longdescription lang="en">
web.py provides small and simple web framework for
diff --git a/dev-python/webpy/webpy-0.51_p20200405.ebuild b/dev-python/webpy/webpy-0.51_p20200405.ebuild
new file mode 100644
index 000000000..1fa426328
--- /dev/null
+++ b/dev-python/webpy/webpy-0.51_p20200405.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+COMMIT="16de3147e61aa4dc735efa116c50603707fb0683"
+
+DESCRIPTION="A web framework for python that is as simple as it is powerful"
+HOMEPAGE="
+ https://www.webpy.org
+ https://github.com/webpy/webpy
+ https://pypi.org/project/web.py
+"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cheroot-6.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/pytest-5.4.1[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+src_prepare() {
+ #tests require postgresql and mysql running
+ rm tests/test_db.py || die
+ default
+}