aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-15 00:46:58 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-15 01:09:42 +0200
commite90f46595b2a1068b09051083798c7c98a09a424 (patch)
tree9e878fbb38ecebb14ff2d61b5ae1408e8551f41a /dev-python
parentdev-python/ufoNormalizer: drop 0.5.2, 0.5.3 (diff)
downloadguru-e90f46595b2a1068b09051083798c7c98a09a424.tar.gz
guru-e90f46595b2a1068b09051083798c7c98a09a424.tar.bz2
guru-e90f46595b2a1068b09051083798c7c98a09a424.zip
dev-python/trio-asyncio: drop 0.11.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trio-asyncio/Manifest1
-rw-r--r--dev-python/trio-asyncio/trio-asyncio-0.11.0.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/trio-asyncio/Manifest b/dev-python/trio-asyncio/Manifest
index d7fbc9f78..a4fd46342 100644
--- a/dev-python/trio-asyncio/Manifest
+++ b/dev-python/trio-asyncio/Manifest
@@ -1,2 +1 @@
-DIST trio-asyncio-0.11.0.tar.gz 67424 BLAKE2B 2d38b621eb5698521ba58c06295f6e2337821c64a35c4938ed9ffd4a01285c95df9c512d9922e88afbdff7c6fc0ef028784a1f189fbc9255ea46ee346b2f892c SHA512 718098f7ab18b168dd6a926d9bb64b636e06e6a1ea8e557ba4bf7782db16bb7fcccf226412284bfbc5183ff6df7624fc1a7ac73dd20bc841ffffd5e766e84d0a
DIST trio-asyncio-0.12.0.tar.gz 72508 BLAKE2B f2dad48e20dadb81f603f8e7edf5d108f5c1dec332e65599e06495a9e3b919d20a15e3cb0d4f06c46a0e844cd79a88c172043b5cae2bc632661679a9ac854c04 SHA512 da630bf95d0736efd419a7b84d3fcb55f4440ef5f3ac584f36b2eca9188145d4581b20d4842b1322b07f176822f7c76e32ae57ac71899ea2445ce1783bcd382c
diff --git a/dev-python/trio-asyncio/trio-asyncio-0.11.0.ebuild b/dev-python/trio-asyncio/trio-asyncio-0.11.0.ebuild
deleted file mode 100644
index c496354dc..000000000
--- a/dev-python/trio-asyncio/trio-asyncio-0.11.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="a re-implementation of the asyncio mainloop on top of Trio"
-HOMEPAGE="
- https://github.com/python-trio/trio-asyncio
- https://pypi.org/project/trio-asyncio
-"
-SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE=" || ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/async_generator-1.6[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- >=dev-python/trio-0.12.0[${PYTHON_USEDEP}]
-"
-
-DEPEND="test? (
- dev-python/pytest-trio[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source
-
-python_prepare_all() {
- # do not depend on deprecated dep
- sed -i -e '/pytest-runner/d' setup.py || die
-
- #remove tests from installed packages
- #TODO: remove hardcoded
- sed -i 's|packages=find_packages()|packages=["trio_asyncio"]|' setup.py || die
-
- distutils-r1_python_prepare_all
-}