aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-09-20 21:02:15 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2020-09-20 21:02:15 +0300
commit50456219d6d9008f4c90a59cc44fa79b25e8d408 (patch)
tree8bbb11a2216de068eb967bf4d39ba2dce35063c2 /dev-util/FoBiS/FoBiS-3.0.5.ebuild
parentdev-vcs/lazygit: 0.22.9 version bump (diff)
downloadguru-50456219d6d9008f4c90a59cc44fa79b25e8d408.tar.gz
guru-50456219d6d9008f4c90a59cc44fa79b25e8d408.tar.bz2
guru-50456219d6d9008f4c90a59cc44fa79b25e8d408.zip
dev-util/FoBiS: version 3.0.5 bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-util/FoBiS/FoBiS-3.0.5.ebuild')
-rw-r--r--dev-util/FoBiS/FoBiS-3.0.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/FoBiS/FoBiS-3.0.5.ebuild b/dev-util/FoBiS/FoBiS-3.0.5.ebuild
new file mode 100644
index 000000000..051cc3654
--- /dev/null
+++ b/dev-util/FoBiS/FoBiS-3.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="FoBiS.py, a Fortran Building System for poor men"
+HOMEPAGE="https://github.com/szaghi/FoBiS"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}.py/${PN}.py-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="graphviz"
+
+S="${WORKDIR}/${PN}.py-${PV}"
+
+RDEPEND="
+ graphviz? ( dev-python/graphviz[${PYTHON_USEDEP}] )
+"
+
+# removing "import future" and "from past.utils import old_div" from python scripts
+PATCHES=( "${FILESDIR}/${PN}-3.0.2-remove-import-future_olddiv.patch" )