aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-04-27 10:29:37 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-04-27 14:50:04 +0500
commit26b60c9829a81782f1e45b2664ea65cfbb910e1e (patch)
tree9387c548518047493f7adabdad61f8e6b8753c65 /dev-util
parentdev-util/gshards: update Manifest (diff)
downloadguru-26b60c9829a81782f1e45b2664ea65cfbb910e1e.tar.gz
guru-26b60c9829a81782f1e45b2664ea65cfbb910e1e.tar.bz2
guru-26b60c9829a81782f1e45b2664ea65cfbb910e1e.zip
dev-util/gshards: drop 0.1-r1
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gshards/files/0.1/gshards-get-pkgname.cr10
-rw-r--r--dev-util/gshards/files/0.1/gshards-has-targets.cr14
-rw-r--r--dev-util/gshards/gshards-0.1-r1.ebuild40
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-util/gshards/files/0.1/gshards-get-pkgname.cr b/dev-util/gshards/files/0.1/gshards-get-pkgname.cr
deleted file mode 100644
index 4a1947221..000000000
--- a/dev-util/gshards/files/0.1/gshards-get-pkgname.cr
+++ /dev/null
@@ -1,10 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-require "yaml"
-
-yaml = File.open("shard.yml") do |file|
- YAML.parse(file)
-end
-
-puts yaml["name"].as_s
diff --git a/dev-util/gshards/files/0.1/gshards-has-targets.cr b/dev-util/gshards/files/0.1/gshards-has-targets.cr
deleted file mode 100644
index 1b2eb308e..000000000
--- a/dev-util/gshards/files/0.1/gshards-has-targets.cr
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-require "yaml"
-
-yaml = File.open("shard.yml") do |file|
- YAML.parse(file)
-end
-
-if yaml["targets"]?
- exit(0)
-end
-
-exit(1)
diff --git a/dev-util/gshards/gshards-0.1-r1.ebuild b/dev-util/gshards/gshards-0.1-r1.ebuild
deleted file mode 100644
index 3e288542c..000000000
--- a/dev-util/gshards/gshards-0.1-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit crystal-utils multiprocessing toolchain-funcs
-
-DESCRIPTION="Small helper tools to aid installing Crystal packages in Gentoo"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-S="${WORKDIR}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-libs/boehm-gc
- dev-libs/libevent:=
- dev-libs/libpcre:3
- dev-libs/libyaml
-"
-DEPEND="${RDEPEND}"
-BDEPEND="${CRYSTAL_DEPS}"
-
-QA_FLAGS_IGNORED='.*'
-
-src_configure() {
- crystal_configure
- tc-export CC
-}
-
-src_compile() {
- for prog in "${FILESDIR}"/${PV}/gshards-*.cr; do
- ecrystal build "${prog}" --verbose --threads=$(makeopts_jobs)
- done
-}
-
-src_install() {
- dobin gshards-*
-}