aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-09-23 19:10:47 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-09-23 19:17:49 +0500
commit1edb9f16fd5c54f0bc5f6f7bb6278d60731beffd (patch)
treeab29332651e09d4517985db4a9484b8765f3692e /dev-vcs/got
parentdev-libs/libphonenumber: Version Bump (diff)
downloadguru-1edb9f16fd5c54f0bc5f6f7bb6278d60731beffd.tar.gz
guru-1edb9f16fd5c54f0bc5f6f7bb6278d60731beffd.tar.bz2
guru-1edb9f16fd5c54f0bc5f6f7bb6278d60731beffd.zip
dev-vcs/got: add 0.60
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-vcs/got')
-rw-r--r--dev-vcs/got/Manifest1
-rw-r--r--dev-vcs/got/got-0.60.ebuild40
-rw-r--r--dev-vcs/got/metadata.xml44
3 files changed, 63 insertions, 22 deletions
diff --git a/dev-vcs/got/Manifest b/dev-vcs/got/Manifest
index 3b345ce17..a16d3ea71 100644
--- a/dev-vcs/got/Manifest
+++ b/dev-vcs/got/Manifest
@@ -1 +1,2 @@
DIST got-0_p20210217.tar.gz 517647 BLAKE2B 4b4f5436c5804aa60038d737de883eb69ce4d4f0f705f7d310722222da38b917d577a09fb37b2317c1a34b1a0aa2b0fe00cf07dcbb350a901fe50dbb31ca6ede SHA512 fb3c60b5d1036d735e775e362c7349720bfeae62c1e8b830417b5edd57c86546a97113f6b10b742b1b3b6146d0a7e41906042c1008551b4d15e2bd0331c7ab2f
+DIST got-portable-0.60.tar.gz 664189 BLAKE2B 2ea2c7680de2fde60d4c862ebb836c9809b686396d8ed9c250b14c5d874f393a30f97281fa601fd1e4a7a19c66d8c71f478fda7fea21f11017dbc2bea593900b SHA512 9139c4187914d3ac93880a1b242e14a4d93e3982251dd6eb346911e76f51cc7f0041b45af712633a1099b727580870572c8f590432e7f51abe3c682cba47b524
diff --git a/dev-vcs/got/got-0.60.ebuild b/dev-vcs/got/got-0.60.ebuild
new file mode 100644
index 000000000..d030d868f
--- /dev/null
+++ b/dev-vcs/got/got-0.60.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN="${PN}-portable"
+DESCRIPTION="Portable version of the Game of Trees version control system"
+HOMEPAGE="https://gameoftrees.org"
+SRC_URI="https://gameoftrees.org/releases/portable/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/openssl:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib:=
+ elibc_Darwin? ( sys-libs/native-uuid )
+ elibc_SunOS? ( sys-libs/libuuid )
+ !elibc_Darwin? ( dev-libs/libbsd )
+ !elibc_Darwin? ( !elibc_SunOS? (
+ app-crypt/libmd
+ sys-apps/util-linux
+ ) )
+"
+BDEPEND="
+ virtual/pkgconfig
+ virtual/yacc
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG CHANGES README TODO )
+
+src_compile() {
+ emake AR=$(tc-getAR) GOT_RELEASE=Yes
+}
diff --git a/dev-vcs/got/metadata.xml b/dev-vcs/got/metadata.xml
index 58f7b6133..cc7f2d574 100644
--- a/dev-vcs/got/metadata.xml
+++ b/dev-vcs/got/metadata.xml
@@ -1,26 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>cyber+gentoo@sysrq.in</email>
- <name>Anna</name>
- </maintainer>
- <longdescription>
- Game of Trees (Got) is a version control system which prioritizes
- ease of use and simplicity over flexibility.
+<maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+</maintainer>
+<longdescription>
+ Game of Trees (Got) is a version control system which prioritizes ease
+ of use and simplicity over flexibility.
- Got uses Git repositories to store versioned data. Git can be used
- for any functionality which has not yet been implemented in Got.
- It will always remain possible to work with both Got and Git on the
- same repository.
- </longdescription>
- <upstream>
- <maintainer>
- <email>thomas@xteddy.org</email>
- <name>Thomas Adam</name>
- </maintainer>
- <bugs-to>mailto:gameoftrees@openbsd.org</bugs-to>
- <doc>https://gameoftrees.org/examples.html</doc>
- <changelog>https://git.gameoftrees.org/gitweb/?p=got-portable.git;a=blob_plain;f=CHANGES</changelog>
- </upstream>
+ Got uses Git repositories to store versioned data. Git can be used for
+ any functionality which has not yet been implemented in Got. It will
+ always remain possible to work with both Got and Git on the same
+ repository.
+</longdescription>
+<upstream>
+ <maintainer>
+ <email>thomas@xteddy.org</email>
+ <name>Thomas Adam</name>
+ </maintainer>
+ <bugs-to>mailto:gameoftrees@openbsd.org</bugs-to>
+ <doc>https://gameoftrees.org/examples.html</doc>
+ <changelog>https://git.gameoftrees.org/gitweb/?p=got-portable.git;a=blob_plain;f=CHANGES</changelog>
+</upstream>
</pkgmetadata>