aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-13 14:12:09 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-13 14:12:09 +0100
commitedeae188d9c7ec083f057164671e92d037f59e01 (patch)
treec801c1007843f708dbd0391866ebf25af5b61027 /dev-vcs
parentapp-misc/ntfy: enable doc use flag (diff)
downloadguru-edeae188d9c7ec083f057164671e92d037f59e01.tar.gz
guru-edeae188d9c7ec083f057164671e92d037f59e01.tar.bz2
guru-edeae188d9c7ec083f057164671e92d037f59e01.zip
dev-vcs/git-extras: no symlinks please
I understand why you would want to do this, however there are also very good reason to not do this: https://forums.gentoo.org/viewtopic-p-8202534.html?sid=290d68129893b7435e6ecf9c528171a2 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-vcs')
-rw-r--r--[l---------]dev-vcs/git-extras/git-extras-5.1.0.ebuild37
-rw-r--r--dev-vcs/git-extras/git-extras-9999.ebuild2
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-vcs/git-extras/git-extras-5.1.0.ebuild b/dev-vcs/git-extras/git-extras-5.1.0.ebuild
index d3040b3a1..da362616c 120000..100644
--- a/dev-vcs/git-extras/git-extras-5.1.0.ebuild
+++ b/dev-vcs/git-extras/git-extras-5.1.0.ebuild
@@ -1 +1,36 @@
-git-extras-9999.ebuild \ No newline at end of file
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Little git extras"
+HOMEPAGE="https://github.com/tj/git-extras"
+
+if [[ $PV == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-vcs/git"
+
+src_compile() { :; }
+
+src_install() {
+ emake install PREFIX="${EPREIFX}"/usr SYSCONFDIR="${EPREFIX}"/etc DESTDIR="${D}"
+
+ rm -rf "${D}"/etc/bash_completion.d
+
+ newbashcomp etc/bash_completion.sh ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins etc/git-extras-completion.zsh _${PN}
+
+}
diff --git a/dev-vcs/git-extras/git-extras-9999.ebuild b/dev-vcs/git-extras/git-extras-9999.ebuild
index c43eeb59f..da362616c 100644
--- a/dev-vcs/git-extras/git-extras-9999.ebuild
+++ b/dev-vcs/git-extras/git-extras-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit bash-completion-r1
-DESCRIPTION="Little git extras."
+DESCRIPTION="Little git extras"
HOMEPAGE="https://github.com/tj/git-extras"
if [[ $PV == 9999 ]]; then