aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-25 14:48:16 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-25 14:48:16 +0100
commitb699f8c3242bede0793a1bccd0e5115080a30819 (patch)
treeb55d376a24e51c6bed0d3a15f59a99d6f2920aa3 /games-action/technic-launcher
parentgames-action/minecraft-launcher: remove unecesairy files dir (diff)
downloadguru-b699f8c3242bede0793a1bccd0e5115080a30819.tar.gz
guru-b699f8c3242bede0793a1bccd0e5115080a30819.tar.bz2
guru-b699f8c3242bede0793a1bccd0e5115080a30819.zip
games-action/technic-launcher: use java-pkg-2 eclass
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'games-action/technic-launcher')
-rw-r--r--games-action/technic-launcher/files/technic-launcher4
-rw-r--r--games-action/technic-launcher/technic-launcher-4.510.ebuild13
2 files changed, 4 insertions, 13 deletions
diff --git a/games-action/technic-launcher/files/technic-launcher b/games-action/technic-launcher/files/technic-launcher
deleted file mode 100644
index 5d98fac3f..000000000
--- a/games-action/technic-launcher/files/technic-launcher
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/usr/bin/env bash
-
-java -jar /opt/technic-launcher/technic-launcher.jar
-
diff --git a/games-action/technic-launcher/technic-launcher-4.510.ebuild b/games-action/technic-launcher/technic-launcher-4.510.ebuild
index 1cf3fc772..9ac25c3de 100644
--- a/games-action/technic-launcher/technic-launcher-4.510.ebuild
+++ b/games-action/technic-launcher/technic-launcher-4.510.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop xdg
+inherit desktop java-pkg-2 xdg
DESCRIPTION="Minecraft launcher for community-made modpacks on the Technic Platform"
HOMEPAGE="https://www.technicpack.net/"
@@ -14,7 +14,7 @@ KEYWORDS="~amd64 ~x86"
LICENSE="technic"
SLOT="0"
-RESTRICT="mirror"
+RESTRICT="bindist mirror"
BDEPEND="media-gfx/imagemagick"
@@ -32,13 +32,8 @@ src_compile() {
}
src_install() {
- dodir /opt/${PN}
- insinto /opt/${PN}/
- newins "${DISTDIR}/${P}.jar" ${PN}.jar
-
- insinto /opt/bin/
- doins "${FILESDIR}/${PN}"
- fperms +x /opt/bin/${PN}
+ java-pkg_newjar "${DISTDIR}/${P}.jar" ${P}.jar
+ java-pkg_dolauncher ${PN} --jar ${P}.jar --java_args "\${JAVA_OPTS}"
newicon -s 16x16 ${PN}-0.png ${PN}.png
newicon -s 32x32 ${PN}-1.png ${PN}.png