aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-05-18 18:16:16 +0900
committerWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-05-18 18:16:16 +0900
commit103fbab9ab0e09f5343679b9d7823d48d4a75cf3 (patch)
tree8dc4b1ea6d9f75e9c9f74b95636cf8cc9c2e77cb /games-fps
parentgames-fps/chocolate-doom: Utilize python_gen_any_dep (diff)
downloadguru-103fbab9ab0e09f5343679b9d7823d48d4a75cf3.tar.gz
guru-103fbab9ab0e09f5343679b9d7823d48d4a75cf3.tar.bz2
guru-103fbab9ab0e09f5343679b9d7823d48d4a75cf3.zip
games-fps/crispy-doom: Utilize python_gen_any_dep
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/crispy-doom/crispy-doom-5.5.2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-fps/crispy-doom/crispy-doom-5.5.2.ebuild b/games-fps/crispy-doom/crispy-doom-5.5.2.ebuild
index f2ca898f0..05f0281dc 100644
--- a/games-fps/crispy-doom/crispy-doom-5.5.2.ebuild
+++ b/games-fps/crispy-doom/crispy-doom-5.5.2.ebuild
@@ -24,14 +24,14 @@ DEPEND="
png? ( media-libs/libpng:= )
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"
-BDEPEND="
- python? (
- ${PYTHON_DEPS}
- dev-python/pillow
- )"
+BDEPEND="python? ( $(python_gen_any_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )"
S="${WORKDIR}"/${PN}-${P}
+python_check_deps() {
+ has_version "dev-python/pillow[${PYTHON_USEDEP}]"
+}
+
src_prepare() {
default
eautoreconf