aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-12-21 18:11:16 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-12-21 18:11:16 +0100
commit1451277695135535a82656ab670ae77b8f73e26b (patch)
tree21608f58a0bb711abbc15381f306c76e2b9b1c9c /games-util
parentmedia-tv/droidcam: allow use of libusbmuxd-2.0 (diff)
downloadguru-1451277695135535a82656ab670ae77b8f73e26b.tar.gz
guru-1451277695135535a82656ab670ae77b8f73e26b.tar.bz2
guru-1451277695135535a82656ab670ae77b8f73e26b.zip
games-util/legendary: Version bump 0.20.5.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/legendary/Manifest1
-rw-r--r--games-util/legendary/legendary-0.20.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/games-util/legendary/Manifest b/games-util/legendary/Manifest
index a3d8717a7..7ac92ec73 100644
--- a/games-util/legendary/Manifest
+++ b/games-util/legendary/Manifest
@@ -1,2 +1,3 @@
DIST legendary-0.20.3.tar.gz 78618 BLAKE2B 5d779364b07eb949d392c808e1a4034a7516a0bbb7b5db0c01a07bdcaa0228040f169f817a99921e90749a3f331cad88037ae9881350c2bc0d12669520d1fbd7 SHA512 59c4189cc5cf6d4524acba8454defd89bdb66e3386d42e6d9604f6a38e9108e0ae03ec0e8fce8a181f3b4328cc24dadef2718d97290c2472544a0b124b1ffc9e
DIST legendary-0.20.4.tar.gz 79394 BLAKE2B 7b4279e7beefc785bf331047cbdd01ef5005630594620665d7ef33e46b728b7d287008c4f92ca1af44ba8fc8442265f50c902aa034c02ec974bd9a219b4cc148 SHA512 13e819a630d21932295c7890b37d249f4c26b9518c86e884a747d742397dc1551190d91efe670139779da961fb52d186a65c52aa5d007eece145ce5701fbaf26
+DIST legendary-0.20.5.tar.gz 81244 BLAKE2B a1d0747bf0d5dd81341453038ef29b4ec78b5fa0e4cb8f40118b99391909f0d1a519490046276c6cb65f97a665216432458b049cfed32e2c5b5cb17feb957627 SHA512 8b5055ab63a822baa030dfea9da810aafae66cc5b16dd8e220fc7cc4d95945174031dccc355b1253554e0fac8bee13cd133ce4e2158ba2ca2521ed27c1b20541
diff --git a/games-util/legendary/legendary-0.20.5.ebuild b/games-util/legendary/legendary-0.20.5.ebuild
new file mode 100644
index 000000000..609a30cf2
--- /dev/null
+++ b/games-util/legendary/legendary-0.20.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A free and open-source replacement for the Epic Games Launcher"
+HOMEPAGE="https://github.com/derrod/legendary"
+SRC_URI="https://github.com/derrod/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"