aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2020-12-02 22:35:56 +0100
committerMaciej Barć <xgqt@protonmail.com>2020-12-02 22:35:56 +0100
commit3057f7e12c4b9177047b19b2bbb8d61cde320cd8 (patch)
tree62af2454248f3bf23ed300395d5a6ef1081a0b59 /gui-apps/coreaction
parentgui-libs/libc*: bump to 4.1.0 (diff)
downloadguru-3057f7e12c4b9177047b19b2bbb8d61cde320cd8.tar.gz
guru-3057f7e12c4b9177047b19b2bbb8d61cde320cd8.tar.bz2
guru-3057f7e12c4b9177047b19b2bbb8d61cde320cd8.zip
gui-apps/core*: bump to 4.1.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com>
Diffstat (limited to 'gui-apps/coreaction')
-rw-r--r--gui-apps/coreaction/Manifest1
-rw-r--r--gui-apps/coreaction/coreaction-4.1.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/gui-apps/coreaction/Manifest b/gui-apps/coreaction/Manifest
index 3f76fdb979..d8f2368cae 100644
--- a/gui-apps/coreaction/Manifest
+++ b/gui-apps/coreaction/Manifest
@@ -1 +1,2 @@
DIST coreaction-4.0.0.tar.gz 1397910 BLAKE2B f8d25c6c9066def7d1a0915deb62135a0c042bc67382dcfa24ebc8ef59e125a0ac2e15b8d9bbaf5cfbd34e5ffbd604a2edfc1398c12a2f7f160365734988bac2 SHA512 47f4289bb69498f0d6ba0ba6b3cbf4cea3ccadf4adb0b57c77ccc26cb1b132ecb908291b0b0dc8dccdedbc5b5c2dec40d6adbfb65f73127df1fef868bba16c1e
+DIST coreaction-4.1.0.tar.gz 1398175 BLAKE2B 2222a351a7c308d958eb5a4ffa8c9200aa0d3d2c8144fbc6123a115622fab7ce4d457ba2f11d56481cd29d4efa2b2d61da9f289cae2deaa90004b009e2ca36e2 SHA512 ac9d4aea8e1f354ebc3aec902bf128bcad5116b660412c293e6a374119057d1d3604894e97b33e7a13a39192b034b18e9925e5a8ba550f9e726c55a7f35df7a3
diff --git a/gui-apps/coreaction/coreaction-4.1.0.ebuild b/gui-apps/coreaction/coreaction-4.1.0.ebuild
new file mode 100644
index 0000000000..4c9b32e693
--- /dev/null
+++ b/gui-apps/coreaction/coreaction-4.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="A side bar for showing widgets for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreaction"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+RESTRICT="mirror test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtsvg
+ gui-libs/libcprime
+ gui-libs/libcsys
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+
+ sed -i 's/CSuite/X-CSuite/' app/"${PN}.desktop" || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ einstalldocs
+
+ emake INSTALL_ROOT="${D}" install
+}