aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Ott <gentoo@desire.ch>2020-09-26 12:54:03 +0200
committerStefan Ott <gentoo@desire.ch>2020-09-26 12:54:36 +0200
commit35a5376e0439fbcfa037d1518f2904c80a191a09 (patch)
treee820e542532e7215bdd104dcbdbac90f3c20efcd /media-gfx
parentdev-python/i3ipc: drop py2_7 (diff)
downloadguru-35a5376e0439fbcfa037d1518f2904c80a191a09.tar.gz
guru-35a5376e0439fbcfa037d1518f2904c80a191a09.tar.bz2
guru-35a5376e0439fbcfa037d1518f2904c80a191a09.zip
media-gfx/grafx2: new package
Signed-off-by: Stefan Ott <gentoo@desire.ch>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/grafx2/Manifest1
-rw-r--r--media-gfx/grafx2/files/grafx2-desktop-file.patch15
-rw-r--r--media-gfx/grafx2/grafx2-2.7.2978.ebuild69
3 files changed, 85 insertions, 0 deletions
diff --git a/media-gfx/grafx2/Manifest b/media-gfx/grafx2/Manifest
new file mode 100644
index 000000000..39b36d2b3
--- /dev/null
+++ b/media-gfx/grafx2/Manifest
@@ -0,0 +1 @@
+DIST grafx2-2.7.2978-src.tgz 1104727 BLAKE2B 7ae308ea7ce3dd10966e85353111c890931a56c9bc496c4d956d89db9609e4e472280df1202e85494929979ee080a7c5daf07b629ed7002291448c87a7547cf6 SHA512 ed8d92b51cf71ee139b7c21206a088ba056642debcbbc6e650bdab9547b53159251d842eb4c5ea46b18859c0f333bad66ed60e4b91d58bacd7f02022ead7a61e
diff --git a/media-gfx/grafx2/files/grafx2-desktop-file.patch b/media-gfx/grafx2/files/grafx2-desktop-file.patch
new file mode 100644
index 000000000..8b6235459
--- /dev/null
+++ b/media-gfx/grafx2/files/grafx2-desktop-file.patch
@@ -0,0 +1,15 @@
+diff -Naur grafx2.orig/misc/unix/grafx2.desktop grafx2/misc/unix/grafx2.desktop
+--- grafx2.orig/misc/unix/grafx2.desktop 2020-03-03 20:32:57.000000000 +0100
++++ grafx2/misc/unix/grafx2.desktop 2020-09-26 04:04:31.315093477 +0200
+@@ -1,9 +1,9 @@
+ [Desktop Entry]
+ Name=GrafX2
+ Comment=Deluxe Paint Clone
+-Exec=grafx2 %f
++Exec=grafx2-sdl %f
+ Terminal=false
+ Type=Application
+ Icon=grafx2
+-Categories=Application;Graphics;
++Categories=Graphics;
+ MimeType=image/lbm;image/iff;image/pcx;image/tga;image/gif;image/bmp;image/x-icon;image/png;
diff --git a/media-gfx/grafx2/grafx2-2.7.2978.ebuild b/media-gfx/grafx2/grafx2-2.7.2978.ebuild
new file mode 100644
index 000000000..fb9aa1b4e
--- /dev/null
+++ b/media-gfx/grafx2/grafx2-2.7.2978.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A pixelart-oriented painting program"
+HOMEPAGE="http://www.pulkomandy.tk/projects/GrafX2"
+SRC_URI="http://www.pulkomandy.tk/projects/GrafX2/downloads/${P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ttf lua"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-desktop-file.patch"
+)
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/freetype
+ media-libs/libpng
+ ttf? ( media-libs/sdl-ttf )
+ lua? ( >=dev-lang/lua-5.1.0 )"
+RDEPEND=""
+
+src_unpack()
+{
+ unpack ${P}-src.tgz && mv ${PN} ${P}
+}
+
+src_prepare()
+{
+ eapply ${PATCHES}
+
+ eapply_user
+
+ cd ${WORKDIR}/${P}/src/
+ sed -i s/lua5\.1/lua/g Makefile
+}
+
+src_compile()
+{
+ use ttf || MYCNF="NOTTF=1"
+ use lua || MYCNF="${MYCNF} NOLUA=1"
+
+ cd ${WORKDIR}/${P}/src/
+ emake ${MYCNF} || die "emake failed"
+}
+
+src_install()
+{
+ cd ${WORKDIR}/${P}/src/
+ emake ${MYCNF} DESTDIR="${D}" PREFIX="/usr" install || die "Install failed"
+}
+
+pkg_postinst()
+{
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm()
+{
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}