aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-21 16:17:29 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-21 16:17:29 +0100
commit0e669c55238f00830e19d0f19bd0d049642ef67e (patch)
tree426ff367d9de3a0134aba99826b155c64c01b4d7 /media-video/vidify-audiosync
parentmedia-video/vidify: Watch live music videos for songs playing (diff)
downloadguru-0e669c55238f00830e19d0f19bd0d049642ef67e.tar.gz
guru-0e669c55238f00830e19d0f19bd0d049642ef67e.tar.bz2
guru-0e669c55238f00830e19d0f19bd0d049642ef67e.zip
media-video/vidify-audiosync: Audio synchronization feature for vidify
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'media-video/vidify-audiosync')
-rw-r--r--media-video/vidify-audiosync/files/vidify-audiosync-9999-debug.patch13
-rw-r--r--media-video/vidify-audiosync/metadata.xml13
-rw-r--r--media-video/vidify-audiosync/vidify-audiosync-9999.ebuild29
3 files changed, 55 insertions, 0 deletions
diff --git a/media-video/vidify-audiosync/files/vidify-audiosync-9999-debug.patch b/media-video/vidify-audiosync/files/vidify-audiosync-9999-debug.patch
new file mode 100644
index 000000000..69061de96
--- /dev/null
+++ b/media-video/vidify-audiosync/files/vidify-audiosync-9999-debug.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index e23d76b..32ace2f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -5,7 +5,7 @@ defines = []
+ args = ['-fno-finite-math-only']
+
+ # "Debug mode" flags by uncommenting them
+-# defines.append(('DEBUG', '1'))
++defines.append(('DEBUG', '1'))
+
+ audiosync = Extension(
+ 'vidify_audiosync',
diff --git a/media-video/vidify-audiosync/metadata.xml b/media-video/vidify-audiosync/metadata.xml
new file mode 100644
index 000000000..20ab94177
--- /dev/null
+++ b/media-video/vidify-audiosync/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-video/vidify-audiosync/vidify-audiosync-9999.ebuild b/media-video/vidify-audiosync/vidify-audiosync-9999.ebuild
new file mode 100644
index 000000000..f4fc153b5
--- /dev/null
+++ b/media-video/vidify-audiosync/vidify-audiosync-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit cmake-utils git-r3 distutils-r1
+
+DESCRIPTION="Audio synchronization feature for vidify "
+HOMEPAGE="https://github.com/vidify/audiosync"
+EGIT_REPO_URI="https://github.com/vidify/audiosync.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=
+
+IUSE="debug"
+
+RDEPEND="
+ media-video/ffmpeg[openssl]
+ media-video/vidify[${PYTHON_USEDEP}]
+ sci-libs/fftw
+ debug? ( sci-visualization/gnuplot )"
+
+src_prepare() {
+ use debug && eapply "${FILESDIR}/${P}-debug.patch"
+ default
+}