aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-05-11 01:29:22 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2020-05-11 01:38:27 +0200
commit3aca34bde7a208d5e0279a3c9ce3bde31781c188 (patch)
treedec0d81d5cdb70522f1f5b4f70dd0ec74a4c9609 /net-im/biboumi
parentnet-im/discord-canary-bin: Renamed and updated (diff)
downloadguru-3aca34bde7a208d5e0279a3c9ce3bde31781c188.tar.gz
guru-3aca34bde7a208d5e0279a3c9ce3bde31781c188.tar.bz2
guru-3aca34bde7a208d5e0279a3c9ce3bde31781c188.zip
net-im/biboumi: Version bump 8.5.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'net-im/biboumi')
-rw-r--r--net-im/biboumi/Manifest1
-rw-r--r--net-im/biboumi/biboumi-8.5.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-im/biboumi/Manifest b/net-im/biboumi/Manifest
index cd0fc7135..3e434ca2c 100644
--- a/net-im/biboumi/Manifest
+++ b/net-im/biboumi/Manifest
@@ -1,2 +1,3 @@
DIST biboumi-8.4.tar.xz 142576 BLAKE2B 3be5f8caf406c480a2750d76eacfe9191bccd8bd0fc2ba0ffe6352bf6f6527ab60f16eb25c9820c063af6c9ff4f1b125eb8d51d53bae4392a0d276e7ad488087 SHA512 69f7a47aaf2729a6bffb047201305cef4b87da952aa103d82e715585bf7b2e97fca8159ced1d74c4b01508c874c0db274d7b8349d1579ee3e69fc0ced2c260c2
+DIST biboumi-8.5.tar.xz 142576 BLAKE2B 0e9284aa757f43a8436a7df5f78962663ca8cbf9b9a24dd5ea9c978e3240274b6f817b00169b478332f28b5f50a96833e10b7a3feec5e16b96638ec94daeb843 SHA512 36aa8c66a720faa8d9f0bd76fcd4ee382b7d21f6822de2a03582d03e8e7e440a4a08b1ff21e876e70e6b5b1012973c9936d85faecf4781a5d78e7d8b206c3ef6
DIST biboumi-9.0_pre20200419.tar.bz2 150555 BLAKE2B 6c73abcd62c7448cfc990c7228b37c0eda57d05ee987ef5c9661ed2bf8b8376e253e9507c03151d7334b5bff7c8e6807188e5e806473deb79d96fb81212cfb1f SHA512 b86485c0aae5cca6b5909eec2159c9b52069aade3e399721826c02f297b6f3d57e0ddcab9df4f6aa32b0219ccfbf1c7c63c1f51e4b8ab051b6d1f4dbbb34789e
diff --git a/net-im/biboumi/biboumi-8.5.ebuild b/net-im/biboumi/biboumi-8.5.ebuild
new file mode 100644
index 000000000..1fa01942e
--- /dev/null
+++ b/net-im/biboumi/biboumi-8.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake fcaps
+
+DESCRIPTION="XMPP gateway to IRC"
+HOMEPAGE="https://biboumi.louiz.org/"
+SRC_URI="https://git.louiz.org/biboumi/snapshot/biboumi-${PV}.tar.xz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+idn logrotate postgres +sqlite +ssl systemd udns"
+
+DEPEND="
+ dev-libs/expat
+ virtual/libiconv
+ sys-apps/util-linux
+ sqlite? ( dev-db/sqlite )
+ postgres? ( dev-db/postgresql:* )
+ idn? ( net-dns/libidn )
+ udns? ( net-libs/udns )
+ ssl? ( dev-libs/botan:2 )
+ !ssl? ( dev-libs/libgcrypt )
+ systemd? ( sys-apps/systemd )
+"
+BDEPEND="app-text/pandoc"
+RDEPEND="
+ ${DEPEND}
+ acct-user/biboumi"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+# Allow biboumi to run an identd on port 113.
+FILECAPS=( cap_net_bind_service+ep usr/bin/biboumi )
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use systemd; then # Don't install biboumi.service.
+ sed -i '/DESTINATION lib\/systemd\/system/d' CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_BOTAN="$(usex ssl)"
+ -DWITH_LIBIDN="$(usex idn)"
+ -DWITH_SYSTEMD="$(usex systemd)"
+ -DWITH_UDNS="$(usex udns)"
+ -DWITH_SQLITE3="$(usex sqlite)"
+ -DWITH_POSTGRESQL="$(usex postgres)"
+
+ -DWITHOUT_SYSTEMD="$(usex systemd no yes)"
+ -DWITHOUT_POSTGRESQL="$(usex postgres no yes)"
+ ) # The WITHOUT_* is really needed.
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if ! use systemd; then
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ fi
+
+ if use logrotate; then
+ insinto etc/logrotate.d
+ if use systemd; then
+ newins "${FILESDIR}/${PN}.logrotate.systemd" "${PN}"
+ else
+ newins "${FILESDIR}/${PN}.logrotate.openrc" "${PN}"
+ fi
+ fi
+
+ diropts --owner=biboumi --group=biboumi --mode=750
+ if use sqlite; then
+ keepdir var/lib/biboumi
+ fi
+ keepdir var/log/biboumi
+
+ insinto etc/biboumi
+ insopts --group=biboumi --mode=640
+ doins conf/biboumi.cfg
+}