aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlarig Le Lay <alarig@swordarmor.fr>2020-03-21 18:59:39 +0100
committerAlarig Le Lay <alarig@swordarmor.fr>2020-03-21 18:59:39 +0100
commit7dc08326af3b84b856422368a311f07046c17ef5 (patch)
tree3e6e1bd06a425064d3d4ba3cb3c384decd2daf2a /net-misc/openbgpd/openbgpd-6.6_p0.ebuild
parentacct-user/_bgpd: New ebuild (diff)
downloadguru-7dc08326af3b84b856422368a311f07046c17ef5.tar.gz
guru-7dc08326af3b84b856422368a311f07046c17ef5.tar.bz2
guru-7dc08326af3b84b856422368a311f07046c17ef5.zip
net-misc/openbgpd: New ebuild
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr>
Diffstat (limited to 'net-misc/openbgpd/openbgpd-6.6_p0.ebuild')
-rw-r--r--net-misc/openbgpd/openbgpd-6.6_p0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/openbgpd/openbgpd-6.6_p0.ebuild b/net-misc/openbgpd/openbgpd-6.6_p0.ebuild
new file mode 100644
index 000000000..6f9d47689
--- /dev/null
+++ b/net-misc/openbgpd/openbgpd-6.6_p0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+MY_PV="${PV/_p/p}"
+#MY_PN="openbgpd-portable"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="OpenBGPD is a free implementation of BGPv4"
+HOMEPAGE="http://www.openbgpd.org/index.html"
+SRC_URI="mirror://openbsd/OpenBGPD/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ acct-group/_bgpd
+ acct-user/_bgpd
+"
+BDEPEND="
+ sys-devel/libtool
+"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}/${MY_P}" "${S}"
+}
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}/${P}-config.c.patch"
+ default
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}-init.d" bgpd
+ newconfd "${FILESDIR}/${PN}-conf.d" bgpd
+ systemd_newunit "${FILESDIR}/${PN}.service" bgpd.service
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "OpenBGPD portable (not running on OpenBSD) can’t export its RIB to"
+ ewarn "the FIB. It’s only suitable for route-reflectors or route-servers."
+ ewarn ""
+}