aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlarig Le Lay <alarig@swordarmor.fr>2020-03-24 21:01:17 +0100
committerAlarig Le Lay <alarig@swordarmor.fr>2020-03-24 21:01:17 +0100
commit41e3b454c6b1b034b60f6073769040102e0021c9 (patch)
treefebb8dc7e87c803f61bb8625023e323b529a8d98 /net-misc
parentx11-misc/tbsm: remove proxy-maint from metadata (diff)
downloadguru-41e3b454c6b1b034b60f6073769040102e0021c9.tar.gz
guru-41e3b454c6b1b034b60f6073769040102e0021c9.tar.bz2
guru-41e3b454c6b1b034b60f6073769040102e0021c9.zip
net-misc/openbgpd: Re-adding a corrected git version
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openbgpd/openbgpd-9999.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/openbgpd/openbgpd-9999.ebuild b/net-misc/openbgpd/openbgpd-9999.ebuild
new file mode 100644
index 000000000..a7ba28443
--- /dev/null
+++ b/net-misc/openbgpd/openbgpd-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools git-r3 systemd
+
+DESCRIPTION="OpenBGPD is a free implementation of BGPv4"
+HOMEPAGE="http://www.openbgpd.org/index.html"
+EGIT_REPO_URI="https://github.com/openbgpd-portable/openbgpd-portable.git"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ !!net-misc/quagga
+ acct-group/_bgpd
+ acct-user/_bgpd
+"
+BDEPEND="
+ dev-util/byacc
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool
+"
+
+src_unpack() {
+ git-r3_src_unpack
+
+ cd "${WORKDIR}"
+
+ EGIT_REPO_URI="https://github.com/openbgpd-portable/openbgpd-openbsd.git"
+ EGIT_BRANCH=$(cat "${S}"/OPENBSD_BRANCH)
+ EGIT_CHECKOUT_DIR="${S}/openbsd"
+ git-r3_fetch
+ git-r3_checkout
+}
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}/${P}-update.patch"
+ eapply -p0 "${FILESDIR}/${P}-config.c.patch"
+ default
+ ./autogen.sh
+ eautoreconf
+}
+
+src_configure() {
+ export YACC=byacc
+ default
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}-init.d" bgpd
+ newconfd "${FILESDIR}/${PN}-conf.d" bgpd
+ systemd_newunit "${FILESDIR}/${PN}.service" bgpd.service
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "OpenBGPD portable (not running on OpenBSD) can’t export its RIB to"
+ ewarn "the FIB. It’s only suitable for route-reflectors or route-servers."
+ ewarn ""
+}