aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-06-06 16:48:57 +0200
committerVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-06-06 16:49:14 +0200
commit83bebc90c0368e697557e78df9bb6d1017e3b15f (patch)
treea0f0dda686e45caa96f511a2e6933f2c2b4fb148 /net-wireless/eiwd
parentnet-misc/wsdd: Version bump to 0.6, add Python 3.8 support (diff)
downloadguru-83bebc90c0368e697557e78df9bb6d1017e3b15f.tar.gz
guru-83bebc90c0368e697557e78df9bb6d1017e3b15f.tar.bz2
guru-83bebc90c0368e697557e78df9bb6d1017e3b15f.zip
net-wireless/eiwd: 20200416 (Version 1.7)
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net>
Diffstat (limited to 'net-wireless/eiwd')
-rw-r--r--net-wireless/eiwd/eiwd-20200416.ebuild56
-rw-r--r--net-wireless/eiwd/eiwd-9999.ebuild1
-rw-r--r--net-wireless/eiwd/files/20200416.patch15
3 files changed, 72 insertions, 0 deletions
diff --git a/net-wireless/eiwd/eiwd-20200416.ebuild b/net-wireless/eiwd/eiwd-20200416.ebuild
new file mode 100644
index 0000000000..1453d6a051
--- /dev/null
+++ b/net-wireless/eiwd/eiwd-20200416.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic git-r3
+
+MY_PV="$(ver_rs 2 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="iwd without dbus"
+HOMEPAGE="https://github.com/dylanaraps/eiwd"
+EGIT_REPO_URI="https://github.com/dylanaraps/eiwd.git"
+# Version 1.7 Apr 16, 2020
+EGIT_COMMIT="7b5545a"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="+resolvconf +system-ell"
+
+DEPEND="system-ell? ( >=dev-libs/ell-0.31 )"
+RDEPEND="${DEPEND}
+ resolvconf? ( || ( net-dns/openresolv net-misc/dhcpcd ) )
+ !net-wireless/iwd
+ net-wireless/wireless-regdb"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/20200416.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags "-fsigned-char"
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/iwd --localstatedir="${EPREFIX}"/var
+ --disable-dbus
+ $(use_enable system-ell external-ell)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib/iwd
+ newinitd "${FILESDIR}"/iwd.initd iwd
+ if use resolvconf ; then
+ insinto /etc/iwd/
+ doins "${FILESDIR}"/main.conf
+ fi
+}
diff --git a/net-wireless/eiwd/eiwd-9999.ebuild b/net-wireless/eiwd/eiwd-9999.ebuild
index 78157c427b..af4ac27505 100644
--- a/net-wireless/eiwd/eiwd-9999.ebuild
+++ b/net-wireless/eiwd/eiwd-9999.ebuild
@@ -11,6 +11,7 @@ MY_P="${PN}-${MY_PV}"
DESCRIPTION="iwd without dbus"
HOMEPAGE="https://github.com/dylanaraps/eiwd"
EGIT_REPO_URI="https://github.com/dylanaraps/eiwd.git"
+EGIT_COMMIT="7b5545a"
LICENSE="LGPL-2.1"
SLOT="0"
diff --git a/net-wireless/eiwd/files/20200416.patch b/net-wireless/eiwd/files/20200416.patch
new file mode 100644
index 0000000000..e559a21c27
--- /dev/null
+++ b/net-wireless/eiwd/files/20200416.patch
@@ -0,0 +1,15 @@
+# Good for EGIT_COMMIT="7b5545a" which is Release 1.7
+# https://github.com/dylanaraps/eiwd/commit/39ef23ea037fe97c060fafbcbd25af684ae0c55e
+
+diff --git a/src/main.c b/src/main.c
+index 549f1bae..2ab44355 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -49,6 +49,7 @@
+ #include "src/backtrace.h"
+
+ static struct l_genl *genl;
++static struct l_netlink *rtnl;
+ static struct l_settings *iwd_config;
+ static struct l_timeout *timeout;
+ static const char *interfaces;