aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-06 19:42:20 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-04-06 19:42:20 +0200
commitae2581bc50c1b570091c341f570d0df859d2dddb (patch)
tree6cd5ce2c2efbfdb0ec2a56f36990327509353871 /sci-geosciences/geographiclib/geographiclib-1.50.ebuild
parentdev-python/geopy: bump masked package (diff)
downloadguru-ae2581bc50c1b570091c341f570d0df859d2dddb.tar.gz
guru-ae2581bc50c1b570091c341f570d0df859d2dddb.tar.bz2
guru-ae2581bc50c1b570091c341f570d0df859d2dddb.zip
sci-geosciences: do not die is use doc
doing this: use x && do_thing || die makes the build die is use -x so don't do that Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-geosciences/geographiclib/geographiclib-1.50.ebuild')
-rw-r--r--sci-geosciences/geographiclib/geographiclib-1.50.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sci-geosciences/geographiclib/geographiclib-1.50.ebuild b/sci-geosciences/geographiclib/geographiclib-1.50.ebuild
index 7f8a351c5..64a438f46 100644
--- a/sci-geosciences/geographiclib/geographiclib-1.50.ebuild
+++ b/sci-geosciences/geographiclib/geographiclib-1.50.ebuild
@@ -110,6 +110,8 @@ DEPEND="
S="${WORKDIR}/${MY_P}"
distutils_enable_tests setup.py
+# there are additional docs in the python dir
+distutils_enable_sphinx python/doc
src_prepare() {
#TODO: strip cflags
@@ -152,6 +154,7 @@ src_compile() {
cd "python" || die
python_foreach_impl distutils-r1_python_compile
cd ".." || die
+ use doc && build_sphinx python/doc
fi
}
@@ -176,6 +179,10 @@ src_install() {
cmake_src_install
+ # remove python things added by the cmake_src_install function
+ # these are installed in the wrong python dir
+ rm -rf "${D}/usr/$(get_libdir)/python" || die
+ # if use python we re-add these python files correctly
if use python; then
cd "python" || die
python_foreach_impl distutils-r1_python_install
@@ -184,8 +191,7 @@ src_install() {
#TODO: find out if java stuff need something
- rm -rf "${D}/usr/$(get_libdir)/python" || die
-
- use doc && mkdir -p "${D}/usr/share/${P}" || die
- use doc && mv "${D}/usr/share/doc/${MY_PN}" "${D}/usr/share/${P}/doc" || die
+ # Installs to wrong doc dir for some reason
+ # Also happens with USE="-doc"
+ mv "${D}/usr/share/doc/${MY_PN}" "${D}/usr/share/doc/${P}" || die
}